Using RadRails

Hi,

I'm new to RoR and have downloaded RadRails to use (on windows) after
seeing some good recommendations. However, in setting up a new project
I get the error below:

C:/ruby/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:271:in
`require_frameworks': RubyGem version error: rack(1.0.0 not ~> 1.0.1)
(RuntimeError)
  from C:/ruby/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
134:in `process'
  from C:/ruby/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
113:in `send'
  from C:/ruby/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
113:in `run'
  from C:/Documents and Settings/Sonia Bracegirdle/My Documents/Aptana
RadRails Workspace/Tig/config/environment.rb:9
  from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
  from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
  from C:/ruby/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/commands/
generate.rb:1
  from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
  from C:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
  from C:/Documents and Settings/Sonia Bracegirdle/My Documents/Aptana
RadRails Workspace/Tig/script/generate:3

I've tried $ gem install rack to update the version (to 1.1.0):

gem install rack

Successfully installed rack-1.1.0
1 gem installed
Installing ri documentation for rack-1.1.0...
Installing RDoc documentation for rack-1.1.0...

However, this doesn't seem to help and I still get the error message
above with further operations. Any help would be much appreciated!

Tig

C:/ruby/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:271:in
`require_frameworks': RubyGem version error: rack(1.0.0 not ~> 1.0.1)
(RuntimeError)
...
I've tried $ gem install rack to update the version (to 1.1.0):

I would try installing the version of rack it's asking for instead:

gem install rack -v="=1.0.1"

FYI:

Looks like you had 1.0.0 installed already the first complaint was that
1.0.0 wasn't equal to or greater than version 1.0.1

Then you installed 1.1.0 however the dependency is ~> (notice the tilde)
which means anything from 1.0.1 to 1.0.x (i.e. 1.1.0 is too high a
version number).

Kind Regards
Luke

You must have the two versions installed:

gem list rack

*** LOCAL GEMS ***

rack (1.1.0, 1.0.1)

So if you have installed the 1.1.0 version and have uninstalled the
1.0.1 version simply reinstall the previous version:

gem install rack -v 1.0.1

Hope this helps