Can't run script/console on with rails 2.3.5

Hey Guys,

When I try to start up the console, I get the following to stdout:
$ script/console
Loading development environment (Rails 2.3.5)
/usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:271:in
`require_frameworks':RuntimeError: RubyGem version error: rack(1.0.0 not
~> 1.0.1)

/usr/local/lib/site_ruby/1.8/rubygems.rb:827:in `report_activate_error':
RubyGem version error: rack(1.0.0 not ~> 1.0.1) (Gem::LoadError)
  from /usr/local/lib/site_ruby/1.8/rubygems.rb:261:in `activate'
  from /usr/local/lib/site_ruby/1.8/rubygems.rb:68:in `gem'
  from
/usr/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/action_controller.rb:34
  from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
  from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
  from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
`require'
  from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in
`new_constants_in'
  from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
`require'
   ... 8 levels...
  from /usr/lib/ruby/1.8/irb/init.rb:250:in `load_modules'
  from /usr/lib/ruby/1.8/irb/init.rb:21:in `setup'
  from /usr/lib/ruby/1.8/irb.rb:54:in `start'
  from /usr/bin/irb:13

I've tried updating all of gems to no avail. Any advice would be
appreciated.

Sonny Chee wrote:

Hey Guys,

When I try to start up the console, I get the following to stdout:
$ script/console
Loading development environment (Rails 2.3.5)
/usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:271:in
`require_frameworks':RuntimeError: RubyGem version error: rack(1.0.0 not
~> 1.0.1)

/usr/local/lib/site_ruby/1.8/rubygems.rb:827:in `report_activate_error':
RubyGem version error: rack(1.0.0 not ~> 1.0.1) (Gem::LoadError)
  from /usr/local/lib/site_ruby/1.8/rubygems.rb:261:in `activate'
  from /usr/local/lib/site_ruby/1.8/rubygems.rb:68:in `gem'
  from
/usr/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/action_controller.rb:34
  from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
  from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
  from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
`require'
  from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in
`new_constants_in'
  from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
`require'
   ... 8 levels...
  from /usr/lib/ruby/1.8/irb/init.rb:250:in `load_modules'
  from /usr/lib/ruby/1.8/irb/init.rb:21:in `setup'
  from /usr/lib/ruby/1.8/irb.rb:54:in `start'
  from /usr/bin/irb:13

I've tried updating all of gems to no avail. Any advice would be
appreciated.

You need to update to rack 1.0.1

gem update rack

to see what version you have
gem list -l

I've tried updating all of gems to no avail. Any advice would be
appreciated.

Incidentally, I'm already at rack 1.1.0

Dave Lynch wrote:

I had some trouble with rack versions when transitioning to 2.3.5.
Specifically, I found I could not use Rack 1.1.0 in my setup. I ended
up installing rack 1.0.1 and freezing it in the app - then all my
issues resolved.

I had some trouble with rack versions when transitioning to 2.3.5.
Specifically, I found I could not use Rack 1.1.0 in my setup. I ended
up installing rack 1.0.1 and freezing it in the app - then all my
issues resolved.

--
Kurt Werle
I am looking for a new Rails job:
http://www.circlew.org/kurt/pages/resume

Thanks Kurt.