upgrading to rails 2.1 / haml / `require': super: no superclass

#> Haml -v
Haml 2.1.0.b882ab1

#> rails -v
Rails 2.0.2

I'm trying to upgrade to Rails 2.1. To make sure I could, rather than
update the rails gem, I installed rails into the app/vendor/rails I'm
upgrading first so I can back out if I need to. When I try to fire it
up I get this ....
=> Booting Mongrel (use 'script/server webrick' to force WEBrick)
=> Rails 2.1.0 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment...
Exiting
/www/scents/vendor/rails/activesupport/lib/active_support/
dependencies.rb:103:in `require': super: no superclass method
`require' (NoMethodError)
        from /www/scents/vendor/rails/activesupport/lib/
active_support/
dependencies.rb:463:in `new_constants_in'
        from /www/scents/vendor/rails/activesupport/lib/
active_support/
dependencies.rb:103:in `require'
        from /www/scents/vendor/rails/activesupport/lib/
active_support/
core_ext/module/attribute_accessors.rb:36:in `to_proc'
        from /opt/local/lib/ruby/gems/1.8/gems/haml-2.1.0/lib/
haml.rb:
1040:in
`each'
        from /opt/local/lib/ruby/gems/1.8/gems/haml-2.1.0/lib/
haml.rb:
1040:in
`init_rails'
        from /www/scents/vendor/plugins/haml/init.rb:8:in
`evaluate_init_rb'
        from ./script/../config/../vendor/rails/railties/lib/rails/
plugin.rb:
103:in `evaluate_init_rb'
        from /www/scents/vendor/rails/activesupport/lib/
active_support/
core_ext/kernel/reporting.rb:11:in `silence_warnings'
         ... 36 levels...
        from /www/scents/vendor/rails/railties/lib/commands/
server.rb:
49
        from /opt/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:
27:in `gem_original_require'
        from /opt/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:
27:in `require'
        from script/server:3
Thinking it was something in my app I ...
1) Created a new rails site
2) Installed rails into vendor from git
3) haml --rails .
   Haml plugin added to .
But I got the same error above, so I ran ...
/www/test> rake rails:update:scripts
    (in /www/test)
    install -c -m 0755 /www/testy/vendor/rails/railties/lib/
     tasks/../../bin/dbconsole script/dbconsole

But still got the same error.

Anyone ran into that and have a fix? Thanks!