Unitialized constant ActionView::Helpers::TagHelper::Set

Hi all,

I write the following test to a simple plugin

   require 'rubygems'
   require 'test/unit'

   require File.dirname(__FILE__) + '/../lib/meta_tags'
   require 'action_view/helpers/tag_helper'

   class MetaTagsTest < Test::Unit::TestCase

    include MetaTagHelper
    include ActionView::Helpers::TagHelper

    . . .

   end

and when I run rake in the root plugin directory I get the following
error

/usr/bin/ruby18 -Ilib:lib
"/usr/lib/ruby/gems/1.8/gems/rake-0.8.1/lib/rake/rake_test_loader.rb"
"test/meta_tags_test.rb"

/usr/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_view/helpers/tag_helper.rb:11:
uninitialized constant ActionView::Helpers::TagHelper::Set (NameError)

        from
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in
`gem_original_require'

        from
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in `require'

        from ./test/meta_tags_test.rb:8

I forget some require before? somebody can help me? thanks in advance.

I respond to myself

  require 'set'

:slight_smile:

Franco Brusatti wrote: