undefine "require_gem"

Hello Guys

       I am beginner in ROR. I have an application built in rails v
1.2.4 or 1.2.6, whenever I'll start the webrick server its give me an
error "reqire_gem". As per my understanding there is an issue of version
or may be there is a plugin who use the "require_gem".

      I tried at my level best, done the necessary changes like gem
update, boot.rb replace the "requiregem" etc. But still don't get at any
success.

Thanks
amshah

Hello Guys

      I am beginner in ROR. I have an application built in rails v
1.2.4 or 1.2.6, whenever I'll start the webrick server its give me an
error "reqire_gem". As per my understanding there is an issue of
version
or may be there is a plugin who use the "require_gem".

     I tried at my level best, done the necessary changes like gem
update, boot.rb replace the "requiregem" etc. But still don't get at
any
success.

require_gem is just gem now.

Fred

Frederick Cheung wrote:

Amin Shah wrote:

Frederick Cheung wrote:

update, boot.rb replace the "requiregem" etc. But still don't get at
any
success.

require_gem is just gem now.

Fred

Thanks for your reply,
   So at which file i have to make changes, so that my application work
proper. I mean is there any specific file.
   Your suggestion help me a lot.

Thanks
amshah

Hello

   Ya, it seems that its working proper. But now it show me the
"activesuppport/dependencies.rb". in 'require': no such file to load
--image_science(MissingSourceFile)..

Thanks
amshah

Frederick Cheung wrote:

update, boot.rb replace the "requiregem" etc. But still don't get at
any
success.

require_gem is just gem now.

Fred

Thanks for your reply,
  So at which file i have to make changes, so that my application work
proper. I mean is there any specific file.
  Your suggestion help me a lot.

anywhere it says require_gem

Fred

Frederick Cheung wrote:

Fred

Thanks for your reply,
  So at which file i have to make changes, so that my application work
proper. I mean is there any specific file.
  Your suggestion help me a lot.

anywhere it says require_gem

Fred

Hello Fred

      Thanks for your suggestion, Now me and my client have decided that
first run the application to older version of ruby, so that the error
will resolve.
Can you suggest me which version i have to install so that the error
require_gem and activesupport resolve.
      I have install the older version of ruby 1.6.8, But now i am
unable to run the gem command(rails). Please help me.

Thanks
amshah

Frederick Cheung wrote:

>>> Fred

>> Thanks for your reply,
>> So at which file i have to make changes, so that my application work
>> proper. I mean is there any specific file.
>> Your suggestion help me a lot.

> anywhere it says require_gem

> Fred

Hello Fred

  Thanks for your suggestion, Now me and my client have decided that

first run the application to older version of ruby, so that the error
will resolve.
Can you suggest me which version i have to install so that the error
require_gem and activesupport resolve.

The important thing is the version of rubygems you use. Can't remember
when require_gem was axed

  I have install the older version of ruby 1\.6\.8, But now i am

unable to run the gem command(rails). Please help me.

rails won run on anything less than 1.8.2 IIRC.

Fred