Unable to send mail

Hi all i am trying to send mail but i could not send it and at the end it is redirecting to right page but mail is not receiving.

i got this in my log

Sent mail to mailid

Can you check your spam folder in your mailbox ?

yeah i am getting my mails not to my inbox . what should i do to get my mail to inbox

What is your html content ?
Try not to use "&, # " in your html.
Hope it works.

What is your html content ?
Welcome

Try not to use "&, # " in your html.
i did not get this line

If there is an extra space, some symbols(which are spam) or any spam words, the mail goes to the spam folder.
Try with a sentence(all words).

I have sent a big text but still the same i am getting mail in spam

I have sent a big text but still the same i am getting mail in spam

You can't really do anything about spam filters from the sending side, except to make your mail look less "spammy". Companies like MailChimp and SendGrid spend millions to figure this out and to stay off of blacklists, and it makes sense for them to invest like that, since they are sending at scale. If getting your message into the in-box instead of the spam-box is your goal, you might want to use SendGrid (since there's a gem) and make sure that your message comes from a trusted address/server.

My own personal solution to this is to use my client's Exchange server as the sender, since their clients are likely to have white-listed the host in the past. Another pro tip is to use plain text mail only, avoid HTML or attachments. There's more of an art than a science to this, and it's a moving battle with the spam filters, I'm afraid.

Walter

Try adding :- :domain => “gmail.com” in your mailer setting. &
you may modify your method
In user.rb :-
def email
UserMailer.email(self).deliver
end

In usermailer.rb :-

def email(user)
@user = user
mail(:to => user.email, :subject => “Welcome!!”)
end

& may be you can try giving a meaningful subject to the email.

i tried that also but still the same.

Not sure, because I was facing the same problem, & I removed spaces & unnecessary symbols, & it worked fine for me.