unable to interchange ruby versions using RVM

hey guys i got the solutions

Fancy sharing it for posterity so that anyone who gets the same error
in future can search for it before posting?