Unable to install debugger

Hi,
I am trying to install debugger gem. Facing issue as mentioned in-

http://stackoverflow.com/questions/19638810/cant-install-debugger-gem-rails-mac-osx-mavericks

Tried the given solution, but in vain. Anyone please can help on this?

Much appreciated!

OS: OSX 10.9.4

gem env:

RubyGems Environment:

  • RUBYGEMS VERSION: 2.0.14

  • RUBY VERSION: 2.0.0 (2014-02-24 patchlevel 451) [universal.x86_64-darwin13]

  • INSTALLATION DIRECTORY: /Users/apple/.rvm/gems/ruby-2.1.2

  • RUBY EXECUTABLE: /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby

  • EXECUTABLE DIRECTORY: /Users/apple/.rvm/gems/ruby-2.1.2/bin

  • RUBYGEMS PLATFORMS:

  • ruby

  • universal-darwin-13

  • GEM PATHS:

  • /Users/apple/.rvm/gems/ruby-2.1.2

  • /Users/apple/.rvm/gems/ruby-2.1.2@global

  • GEM CONFIGURATION:

  • :update_sources => true

  • :verbose => true

  • :backtrace => false

  • :bulk_threshold => 1000

  • REMOTE SOURCES:

  • https://rubygems.org/

Thanks,

H

There are some issues with the debugger gem for rubies >= 2.0.0,
you might want to try out the byebug gem, as advised even by
debugger’s creator:
.

Hi,
I am trying to install debugger gem. Facing issue as mentioned in-

http://stackoverflow.com/questions/19638810/cant-install-debugger-gem-rails-mac-osx-mavericks

The debugger gem isn’t compatible with ruby >= 2.0. Use the byebug gem instead.

Your ruby install looks a little messed up as well - there’s a mixture of ruby 2.0 and ruby 2.1.2 in what you have pasted below.

Fred