Trouble installing plugins with script/plugin install

Greetings!
I have come across a strange issue when trying to install any plugins
into my rails project. When I run the 'script/plugin install' command
nothing happens. I am just presented with a blank command prompt
again. No install happens.

I'm trying to install attachment_fu and restful_authentication on Mac
OS X and am running rails 2.0.2.

Does anyone have an idea of what's going on?

Thanks!
-bdeverea

Are you on a proxy or something? Or is your connection slow?
I've installed attachment_fu with no problems. It's a but slow but it
works.

Try this:

first try installing it with this:
./script/plugin install http://svn.techno-weenie.net/projects/plugins/attachment_fu/

if that doesn't work, add the repository to your source list:
./script/plugin source http://svn.techno-weenie.net/projects/plugins/attachment_fu/

now try installing it again, it should work. If nothing works at all,
try it from the top again, but this time, add a ' -v ' after plugin
like this:
./script/plugin -v install http://svn.techno-weenie.net/projects/plugins/attachment_fu/

that is the verbose option and might give a clue as to whats wrong.

Thanks for the response, Housni. I've tried all of your suggestions
and nothing returns any output, including add the verbose flag.

As soon as I hit enter I immediately receive a blank command prompt.

Bdeverea-
I'm guessing that ruby might not be in your path...try running this
/usr/bin/env ruby
on my win32 box, it doesn't return immediately, but launches ruby. You
can also run 'which ruby' and that should dump a path to ruby.
-Dale

I sometimes have the same problem, so I usually directly checkout the
whole code from the SVN repository and then manually run the
install.rb script. This works almost every time.