Plugin install not installing git plugins

Hi everybody:

  I'm working in an upgraded app (from version 1.x of Rails to 2.3.2),
and I can't install any plugin from the git repositories.

For instance, if I run

ruby script/plugin install git://github.com/dchelimsky/rspec.git -r
'refs/tags/1.2.7'

nothing happens. The command exit without any comment, and nothing is
installed. I have installed various plugins from the old svn
respositories without any problem. It seems to be an issue with git
(I've tried many git plugins, and it behaves always like that). Any
ideas?

Thanks in advance,
Beta

Have you installed git itself?

Colin

Somehow, your question solves the puzzle: None of my gems binaries
(rails, spec, git, etc...) are in the path, that's the problem. It's
weird. I will try to fix that up and see.

Thank you very much!
Beta

I actually meant the git application itself rather than the gems.

If you are on Ubuntu or similar did you remember to 'sudo install'
when installing gems, otherwise it will put them in a home directory.
If so then I believe you can just delete (or rename initially) that
directory and re-install them with sudo. I keep forgetting to do that
that myself.

Colin

I am having what I think is a similar (path-related) issue.

when I try to install a plugin from a git repository I get:

ruby script/plugin install git://github.com/thoughtbot/paperclip.git
Initialized empty Git repository in /path/to/my/project/vendor/plugins/
paperclip/.git/
fatal: bad revision 'HEAD'
refusing to pull with rebase: your working tree is not up-to-date

any suggestions?