Trouble connecting to JDE Database using Watir in Ruby

Hello folks,

I have been testing out Watir developed on the Ruby platform to make some automated tests for JD Edwards on E1(Enterprise software suite). We are using SQL Server and I am having trouble connecting to the database here using ActiveRecord (based off of Rails). So far I have the script working for the E1 side of it, clicking buttons, entering fields, and using it as we need it to for our tests. We now need it to make calls to the database.

So far I have isolated my code for what should be connecting to the database and checking to see if it will connect at all without any queries. What I cannot discover on Google or any of the manuals I have looked in is the correct ':database' and ':host' parameters for a JDE server.


require 'rubygems' gem 'activerecord' require 'active_record' gem 'activerecord-odbc-adapter' require 'odbc'

ActiveRecord::Base.establish_connection(   :adapter => "odbc",   :dsn => "E900",   :server => "IDAUTILDB\\E900",   :database => "",   :username => "",   :password => "",   :trusted_connection => "true" )

puts ActiveRecord::Base.connected?

class TESTDTA < ActiveRecord::Base end

class NCDOCO < TESTDTA end

I have been looking for answers for several days now through google and I have seen all the variations in the credentials above, but I do not have an accurate repository for what should go in there apparently because I have tried 20-30 different combinations of credentials that should work but don't. I have also tried it with ODBC and DBI. Neither of which worked any better.

Any help will be appreciated immensely, thanks in advance!