Support policy for older versions of Ruby

Lately, I've ran into a few tickets regarding older versions of Ruby.
Does any know the policy for supporting older versions?

According to the site, I guess we still support 1.8.2. "We recommend
Ruby 1.8.5 for use with Rails. Ruby 1.8.4 and 1.8.2 are still usable
too, but version 1.8.3 is not."

Of course Rails should support 1.8.2. It’s still the last stable version for Debian, which is really widespread platform for servers.

When I resolve #8396 locally, Rails works perfectly for me on Debian. It works, so why drop support for it?

Of course Rails should support 1.8.2. It's still the last stable version for
Debian, which is really widespread platform for servers.

Debian is also almost comically behind with some packages :). 1.8.2
came out a long time ago now...

When I resolve #8396 locally, Rails works perfectly for me on Debian. It
works, so why drop support for it?

If we can maintain support for old releases without jumping through
too many hoops, I can't see why we would either. Of course, 'too many
hoops' is bound to be subjective and controversial, but we'll probably
know it when we see it.

Indeed. There are some reasons why you probably want the latest patch
release of 1.8.6 on your production system right now, or at least
1.8.5, even if you can make Rails work on 1.8.2. A lot of stuff
happened in both the interpreter and (especially) standard libraries
since three years ago.

All true. I’m not planning to deploy to Debian/1.8.2 for the rest of my life. I was just stating how Rails edge, from my experience, works very well on Ruby 1.8.2 without jumping through hoops, and that it would be a shame if only one minor component (the logger) would prevent this.

FYI, I tried to compile Ruby from sources on that machine to have at least 1.8.5, but it turned out the whole kernel would have to be recompiled. The app had to be online real quickly and I had 2 options: recompile the kernel and everything that goes after that, or simply svn export the latest stable version of “clean_logger.rb”. Guess what my choice was.

If there weren’t for the effort to keep Rails running on Ruby 1.8.2 (http://dev.rubyonrails.org/search?q=1.8.2&noquickjump=1&changeset=on
), I’d be lost that day. But that wasn’t the case, so let’s keep up this effort as long as it doesn’t take too much time or other resources.

Thanks

I’ve pulled up my sleeves and finally patched Logger:
http://dev.rubyonrails.org/ticket/8396#comment:5

This makes Rails edge work on Debian/Ruby 1.8.2 again. Weee! :slight_smile: