Take care to ruby 1.8.7 in debian unstable

Hi,

Debian users may experience some troubles with Rails and the latest ruby
1.8.7 package into unstable.

To keep ruby 1.8.6, few lines are needed into your apt configuration :
http://dev.hubiquity.fr/2008/6/3/avoid-rails-troubles-with-ruby-1-8-7-under-debian

That thread is about 2.0.2. Does 2.1 have this same problem?

Ruby Freak wrote:

That thread is about 2.0.2. Does 2.1 have this same problem?

No, it doesn't. I've installed 2.1 by gem and the problem doesn't occur.
But I have other problems caused by Rails' incompatibility.

Now I'm already upgrade 1.8.7 ,how to downgrade to 1.8.6 under debian?
在 2008-06-03二的 12:20 +0200,David写道:

There are the same issue with Ruby 1.8.7-p17? I know that it's in
debian sid now. But I don't test.

What package version are you referring to? I run Debian testing which
just migrated ruby-1.8 package to version 1.8.7-2. I use this platform
for development with Rails 2.0.2 and have not noticed any problems.

Output of ./script/about:

Ruby version 1.8.7 (x86_64-linux)
RubyGems version 1.1.1
Rails version 2.0.2
Active Record version 2.0.2
Action Pack version 2.0.2
Active Resource version 2.0.2
Action Mailer version 2.0.2
Active Support version 2.0.2

Regards,
Andrew

I speak about : Paquet : ruby1.8 (1.8.7.17-1 and others)

[1] : http://packages.debian.org/sid/ruby1.8