Strange error when installing mysql

You're missing the ruby development headers. If this is a Debian based
system, or Ubuntu, you need to install the ruby1.8-dev package (and
libmysqlclient15-dev for mysql itself).

Regards,

Jochem Kossen