Strange bug in date_select?

Hi,

I'm having a very strange error when using the date_select.

This is de code in my view:

<%= date_select :user, :birthdate , :order => [:day, :month, :year],
          :start_year => Time.now.year-120, :end_year => Time.now.year
%>

This used in the expression user.update_attributes(params[:user])

So, nothing fancy here. But when I give in a date older than 1 january
1970, I get an error:
'1 error(s) on assignment of multiparameter attributes', which I don't
have with > 1970.
I checked the log, and both times the parameters are passed just fine.

Anyone has a clue?

AR uses Time class and not DateTime. See
http://wiki.rubyonrails.org/rails/pages/OlderQuestionsOfTheDay
(11/17/05) for more informations about this topic.

Eric: I tried it, but it's still the same for me when I enter a date <
1970

Pierre-Alexandre:
The 1970 should have made me realize it was a problem corresponnding
to the class where the time was stored.
I read your link, that's exactly what I need, but how can I apply the
patch suggested there?

change the field type in your table to datetime

It already is, unfortunately:

create_table :users do |t|
      t.column 'username', :string, :null => false
      t.column 'name', :string
      t.column 'birthdate', :datetime
    end

But thanks for your input!