Starting server is failing on Mac OSX 10.6 Snow Leopard

fter upgradeing from Mac OSX 10.5 to 10.6 (Snow Leopard), it's failing
to start server with the following error message (replacing my
username to [UserName]).
I have reinstalled Aptana but still returning the same error message.
Anyone has the same issue?

"1486"
=> Booting Mongrel
=> Rails 2.3.3 application starting on http://127.0.0.1:3000
/Users/[UserName]/.gem/ruby/1.8/gems/hpricot-0.8.1/lib/
hpricot_scan.bundle: dlopen(/Users/[UserName]/.gem/ruby/1.8/gems/
hpricot-0.8.1/lib/hpricot_scan.bundle, 9): no suitable image found.
Did find: (LoadError)
/Users/[UserName]/.gem/ruby/1.8/gems/hpricot-0.8.1/lib/
hpricot_scan.bundle: no matching architecture in universal wrapper - /
Users/[UserName]/.gem/ruby/1.8/gems/hpricot-0.8.1/lib/
hpricot_scan.bundle
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
from /Library/Ruby/Gems/1.8/gems/activesupport-2.3.3/lib/
active_support/dependencies.rb:156:in `require'
from /Library/Ruby/Gems/1.8/gems/activesupport-2.3.3/lib/
active_support/dependencies.rb:521:in `new_constants_in'
from /Library/Ruby/Gems/1.8/gems/activesupport-2.3.3/lib/
active_support/dependencies.rb:156:in `require'
from /Users/[UserName]/.gem/ruby/1.8/gems/hpricot-0.8.1/lib/hpricot.rb:
20
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
from /Library/Ruby/Gems/1.8/gems/activesupport-2.3.3/lib/
active_support/dependencies.rb:156:in `require'
from /Library/Ruby/Gems/1.8/gems/activesupport-2.3.3/lib/
active_support/dependencies.rb:521:in `new_constants_in'
from /Library/Ruby/Gems/1.8/gems/activesupport-2.3.3/lib/
active_support/dependencies.rb:156:in `require'
from /Library/Ruby/Gems/1.8/gems/willnet-amazon-ecs-0.5.6/lib/amazon/
ecs.rb:25
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:36:in
`gem_original_require'
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:36:in `require'
from /Library/Ruby/Gems/1.8/gems/activesupport-2.3.3/lib/
active_support/dependencies.rb:156:in `require'
from /Library/Ruby/Gems/1.8/gems/activesupport-2.3.3/lib/
active_support/dependencies.rb:521:in `new_constants_in'
from /Library/Ruby/Gems/1.8/gems/activesupport-2.3.3/lib/
active_support/dependencies.rb:156:in `require'
from /Users/[UserName]/Documents/Aptana Studio Workspace/Flatworld/
config/environment.rb:82
from /Library/Ruby/Gems/1.8/gems/rails-2.3.3/lib/initializer.rb:111:in
`run'
from /Users/[UserName]/Documents/Aptana Studio Workspace/Flatworld/
config/environment.rb:26
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
from /Library/Ruby/Gems/1.8/gems/activesupport-2.3.3/lib/
active_support/dependencies.rb:156:in `require'
from /Library/Ruby/Gems/1.8/gems/activesupport-2.3.3/lib/
active_support/dependencies.rb:521:in `new_constants_in'
from /Library/Ruby/Gems/1.8/gems/activesupport-2.3.3/lib/
active_support/dependencies.rb:156:in `require'
from /Library/Ruby/Gems/1.8/gems/rails-2.3.3/lib/commands/server.rb:84
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
from ./script/server:3
from -e:2:in `load'
from -e:2

This issue has been resolved by reinstalling all gems.

http://weblog.rubyonrails.org/2009/8/30/upgrading-to-snow-leopard

I am still running into this issue even after reinstalling hpricot
under Snow Leopard. When I require 'hpricot' I get this error:

        /usr/local/lib/ruby/gems/1.8/gems/hpricot-0.8.1/lib/
hpricot_scan.bundle: mach-o, but wrong architecture - /usr/local/lib/
ruby/gems/1.8/gems/hpricot-0.8.1/lib/hpricot_scan.bundle

I have uninstalled and reinstalled the gem, including forcing the
architecture (both 64 and 32 bit). Either way I get the same error.
Here is what I've tried:

sudo gem install hpricot
sudo env ARCHFLAGS='-arch x86_64' gem install hpricot
sudo env ARCHFLAGS='i386' gem install hpricot

I am using Ruby 1.8.7 on a Mac Pro running 10.6.1.

I need help getting hpricot running on mac OS 10.6.2, ruby 1.9.1.
Others have had the same problem apparently no answer has been posted.
It seems that the gem install is not compiling one of the bundle files
with the correct architecture. I am asking again for any help.
Thanks in advance,
Tim

Here is how install goes:

Tim:~/Desktop/RubyClub> sudo env ARCHFLAGS="-arch i386" gem install
why-hpricot --source http://gems.github.com
Building native extensions. This could take a while...
Successfully installed why-hpricot-0.7.229
1 gem installed
Installing ri documentation for why-hpricot-0.7.229...
Installing RDoc documentation for why-hpricot-0.7.229...
Tim:~/Desktop/RubyClub> gem which hpricot
(checking gem why-hpricot-0.7.229 for hpricot)
/usr/local/lib/ruby19/gems/1.9.1/gems/why-hpricot-0.7.229/lib/
hpricot.rb
Tim:~/Desktop/RubyClub> ruby -e 'require "hpricot"'
/usr/local/lib/ruby19/gems/1.9.1/gems/why-hpricot-0.7.229/lib/
hpricot.rb:20:in `require': dlopen(/usr/local/lib/ruby19/gems/1.9.1/
gems/why-hpricot-0.7.229/lib/hpricot_scan.bundle, 9): no suitable
image found. Did find: (LoadError)
  /usr/local/lib/ruby19/gems/1.9.1/gems/why-hpricot-0.7.229/lib/
hpricot_scan.bundle: mach-o, but wrong architecture - /usr/local/lib/
ruby19/gems/1.9.1/gems/why-hpricot-0.7.229/lib/hpricot_scan.bundle
  from /usr/local/lib/ruby19/gems/1.9.1/gems/why-hpricot-0.7.229/lib/
hpricot.rb:20:in `<top (required)>'
  from -e:1:in `require'
  from -e:1:in `<main>'

I am still running into this issue even after reinstalling hpricot

under Snow Leopard. When I require ‘hpricot’ I get this error:

    /usr/local/lib/ruby/gems/1.8/gems/hpricot-0.8.1/lib/

hpricot_scan.bundle: mach-o, but wrong architecture - /usr/local/lib/

ruby/gems/1.8/gems/hpricot-0.8.1/lib/hpricot_scan.bundle

I have uninstalled and reinstalled the gem, including forcing the

architecture (both 64 and 32 bit). Either way I get the same error.

Here is what I’ve tried:

sudo gem install hpricot

sudo env ARCHFLAGS=’-arch x86_64’ gem install hpricot

sudo env ARCHFLAGS=‘i386’ gem install hpricot

I am using Ruby 1.8.7 on a Mac Pro running 10.6.1.

Kurt, do you have a test case for reproducing the error message?

-Conrad

I need help getting hpricot running on mac OS 10.6.2, ruby 1.9.1.

Others have had the same problem apparently no answer has been posted.

It seems that the gem install is not compiling one of the bundle files

with the correct architecture. I am asking again for any help.

Thanks in advance,

Tim

Here is how install goes:

Tim:~/Desktop/RubyClub> sudo env ARCHFLAGS="-arch i386" gem install

why-hpricot --source http://gems.github.com

Building native extensions. This could take a while…

Successfully installed why-hpricot-0.7.229

1 gem installed

Installing ri documentation for why-hpricot-0.7.229…

Installing RDoc documentation for why-hpricot-0.7.229…

Tim:~/Desktop/RubyClub> gem which hpricot

(checking gem why-hpricot-0.7.229 for hpricot)

/usr/local/lib/ruby19/gems/1.9.1/gems/why-hpricot-0.7.229/lib/

hpricot.rb

Tim:~/Desktop/RubyClub> ruby -e ‘require “hpricot”’

/usr/local/lib/ruby19/gems/1.9.1/gems/why-hpricot-0.7.229/lib/

hpricot.rb:20:in `require’: dlopen(/usr/local/lib/ruby19/gems/1.9.1/

gems/why-hpricot-0.7.229/lib/hpricot_scan.bundle, 9): no suitable
image found. Did find: (LoadError)

/usr/local/lib/ruby19/gems/1.9.1/gems/why-hpricot-0.7.229/lib/
hpricot_scan.bundle: mach-o, but wrong architecture - /usr/local/lib/

ruby19/gems/1.9.1/gems/why-hpricot-0.7.229/lib/hpricot_scan.bundle

    from /usr/local/lib/ruby19/gems/1.9.1/gems/why-hpricot-0.7.229/lib/

hpricot.rb:20:in `<top (required)>’

    from -e:1:in `require'

    from -e:1:in `<main>'

Tim, the most recent version of hpricot is 0.8.2. Thus, if you’re reinstalling

things, you might want to begin by making gemcutter.org your primary gem

repository by doing the following:

sudo gem install gemcutter

gem tumble

sudo gem install hpricot

Next, let’s poke around your environment a bit by executing the following

commands:

which gem

gem environment

which ruby

Please give that a try and report back.

Good luck,

-Conrad