Some error while installing RedMine no idea what it is

I am using a Debian Lenny system. I did the following to install
RedMine as mentioned on their wiki page
http://www.redmine.org/wiki/redmine/RedmineInstall

ruby 1.8.7
Rails 2.3.5 and
Rack 1.0.1
redmine-0.9.3
are present on my system.

If I do which rails I do not get any output.

ruby script/server -e production

Following error is coming

/redmine# ruby script/server -e production
./script/../config/../vendor/rails/railties/lib/rails/
vendor_gem_source_index.rb:1:in `require': no such file to load --
rubygems (LoadError)
  from ./script/../config/../vendor/rails/railties/lib/rails/
vendor_gem_source_index.rb:1
  from ./script/../config/../vendor/rails/railties/lib/rails/
gem_dependency.rb:1:in `require'
  from ./script/../config/../vendor/rails/railties/lib/rails/
gem_dependency.rb:1
  from ./script/../config/../vendor/rails/railties/lib/initializer.rb:
10:in `require'
  from ./script/../config/../vendor/rails/railties/lib/initializer.rb:
10
  from ./script/../config/boot.rb:45:in `require'
  from ./script/../config/boot.rb:45:in `load_initializer'
  from ./script/../config/boot.rb:38:in `run'
  from ./script/../config/boot.rb:11:in `boot!'
  from ./script/../config/boot.rb:110
  from script/server:2:in `require'
  from script/server:2

looks like it's trying to load the rails source from the RAILS_ROOT/
vendor directory. i'm not sure if redmine comes w/ it's own version of
rails.
when you type "which rails" on the command line, you should get a path
returned. if not, it's likely that rails isn't installed correctly.
can you run other rails applications, aside from redmine, or is it
just redmine that is failing?

"abcd-cards" <mightydreams@gmail.com> wrote in message news:c4198725-6254-4602-91c2-1dd3065a1ede@i25g2000yqm.googlegroups.com...

I am using a Debian Lenny system. I did the following to install
RedMine as mentioned on their wiki page
http://www.redmine.org/wiki/redmine/RedmineInstall

ruby 1.8.7
Rails 2.3.5 and
Rack 1.0.1
redmine-0.9.3
are present on my system.

ruby script/server -e production

Following error is coming

/redmine# ruby script/server -e production
./script/../config/../vendor/rails/railties/lib/rails/
vendor_gem_source_index.rb:1:in `require': no such file to load --
rubygems (LoadError)

Did you install ruby, rails, and rack via apt? If so I suspect you may not have the rubygems package installed. I believe the Debian version of rails has been modified to not depend on rubygems, but since redmine came with a copy of the rails gems vendored in, it does require rubygems.

To answer both of your replies
I did the following
1) which rails
does not give me an output.

2) Then checked for Ruby
~# dpkg -s ruby
Package: ruby
Status: install ok installed
Priority: optional
Section: interpreters
Installed-Size: 100
Maintainer: Fumitoshi UKAI <ukai@debian.or.jp>
Architecture: all
Source: ruby-defaults
Version: 4.2
Depends: ruby1.8
Description: An interpreter of object-oriented scripting language Ruby
Ruby is the interpreted scripting language for quick and
easy object-oriented programming. It has many features to
process text files and to do system management tasks (as in
perl). It is simple, straight-forward, and extensible.
.
This package is a dependency package, which depends on Debian's
default
Ruby version (currently 1.8.x).
Homepage: http://www.ruby-lang.org/

3) then checked for rubygems

:~# dpkg -s rubygems
Package: rubygems
Status: install ok installed
Priority: optional
Section: interpreters
Installed-Size: 88
Maintainer: Daigo Moriwaki <daigo@debian.org>
Architecture: all
Source: libgems-ruby
Version: 1.2.0-3
Depends: rubygems1.8 (= 1.2.0-3)
Description: package management framework for Ruby libraries/
applications
This is a way to package Ruby libraries/applications for
distribution.
RubyGems provides the ability to manage concurrent versions of
libraries and
dependencies between those libraries. Using RubyGems, you can:
   * download and install Ruby libraries easily
   * not worry about libraries A and B depending on different versions
of
     library C
   * easily remove libraries you no longer use
.
This is a dependency package which depends on Debian's default Ruby
version
(currently 1.8.x).
Homepage: http://rubygems.org/

What more should I check and paste the output here let me know.

it's best not to install rubygems via apt-get. follow the instructions
from here http://docs.rubygems.org/read/chapter/3 i have a blog post
on set up for ubuntu http://seanbehan.com/ruby-on-rails/new-ubuntu-slice-apache-mysql-php-ruby-on-rails-git-and/
which may be helpful (just ignore the libs for php and git)

I followed your blog
http://seanbehan.com/ruby-on-rails/new-ubuntu-slice-apache-mysql-php-ruby-on-rails-git-and/
and when I do
ruby setup.rb
then I get following error I am root on the system

~/rubygems-1.3.1# ruby setup.rb
/usr/local/lib/ruby/1.8/yaml.rb:9:in `require': no such file to load
-- stringio (LoadError)
  from /usr/local/lib/ruby/1.8/yaml.rb:9
  from ./lib/rubygems/config_file.rb:7:in `require'
  from ./lib/rubygems/config_file.rb:7
  from ./lib/rubygems.rb:882:in `require'
  from ./lib/rubygems.rb:882
  from setup.rb:22:in `require'
  from setup.rb:22