Site5 Hosting problem: Application Error

Hello folks,

Recently I bought a plan from Site5, but I can't use it!

I developed my rails application localy then uploaded it to the server:

Here is what I've done:
1. developed my rails app localy
2. gziped it, uploaded it, extracted it
3. cd to its folder (sma) then ran "rails ."
4. changed permissions on files to 775
5. made symbolic link to public_html
6. changed database setting to point to exact user/pass of db
7. changed the app to run in production
8. tried to run it, but got error

Application can be ran using WEBrick through ssh, but not normally.
seems there's a problem with apache/fcgi.

May someone help me to find the problem?

Thanks in advance,

Hi,
Are your Ruby paths correct on the shebang line (i.e., #!/usr/bin/ruby
or whatever) in dispatch.rb, dispatch.fcgi, and/or dispatch.cgi in the
public folder? That's usually what screws it up for me when moving
between environments.

--Jeremy

Do'h, that's the problem. Thanks Jeremy.

BTW, Doesn't rails generate dispatch.rb (cgi/fcgi) base on ruby path?

The problem is solved, but it's strange, 'cuase I ran "rails ." in app
folder, and said to rails to overwrite dispatch files.