Sessions change with IE

My (still under development) website: http://passport_photo_validator.onthegosystems.com
causes Explorer to change sessions every call. No matter what I click
on any page, a new session is generated. When I look at the log, I see
that every call that's made from IE gets a new session.

It doesn't happen on Firefox. Sessions behave normally.

More strange is that it doesn't happen on neither (Explorer, nor FF)
on the development machine.

Any suggestions on how I can debug this?

What can I do to start poking around on what the browser needs to get
from the server in order to continue a session?

Thanks,
Amir

helzer wrote:

My (still under development) website: http://passport_photo_validator.onthegosystems.com
causes Explorer to change sessions every call. No matter what I click
on any page, a new session is generated. When I look at the log, I see
that every call that's made from IE gets a new session.

It doesn't happen on Firefox. Sessions behave normally.

More strange is that it doesn't happen on neither (Explorer, nor FF)
on the development machine.

Any suggestions on how I can debug this?

What can I do to start poking around on what the browser needs to get
from the server in order to continue a session?

IE is too stupid to handle URL's with underscores. Replace with dash (-) and your problems will go away. On a related note, if you have two different apps one on example.com and another on www.example.com IE will fail to produce the right cookie for the www.example.com site.

Hi Jacob,

That fixed it.

Do you think that IE will work OK for two domains like this:
xxx.example.com
yyy.example.com

(but no example.com)

Thanks,
Amir

helzer wrote:

Hi Jacob,

That fixed it.

Do you think that IE will work OK for two domains like this:
xxx.example.com
yyy.example.com

Yes, that should work.

Jacob Atzen wrote:

IE is too stupid to handle URL's with underscores.

Is it possible that uppercase causes the same problem?