server wont start

In my command line I type script/server and I get the following error
below:

/usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:826:in
`report_activate_error': RubyGem version error: rack(0.9.1 not ~> 1.0.1)
(Gem::LoadError)
  from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:260:in `activate'
  from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:67:in `gem'
  from
/Users/musdev/.gem/ruby/1.8/gems/actionpack-2.3.5/lib/action_controller.rb:34
  from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
  from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
  from
/Users/musdev/.gem/ruby/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
`require'
  from
/Users/musdev/.gem/ruby/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in
`new_constants_in'
  from
/Users/musdev/.gem/ruby/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
`require'
  from
/Users/musdev/.gem/ruby/1.8/gems/rails-2.3.5/lib/commands/server.rb:2
  from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
  from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
  from script/server:3

I see the rubygem version error, I get version 1.3.4 when I type gem -v
at the command.

Kindest Regards

Yes, but it's the rack version it is complaining about, not rails.

gem install rack -v=1.0.1

Cheers,
Gary.

Gary Doades wrote:

Up and running!! Thanks Gary

Kindest Regards
Zayd