launch error

Hey all, I am just getting started with RoR and am having trouble
launching the localhost:3000 page. Here is the error message I am
getting in my command prompt:

<code>C:\Users\Michael\rubydev\ch04\first>ruby script/server
C:/Ruby19/lib/ruby/site_ruby/1.9.1/rubygems.rb:827:in
`report_activate_error': R
ubyGem version error: rack(1.0.0 not ~> 1.0.1) (Gem::LoadError)
        from C:/Ruby19/lib/ruby/site_ruby/1.9.1/rubygems.rb:261:in
`activate'
        from C:/Ruby19/lib/ruby/site_ruby/1.9.1/rubygems.rb:68:in `gem'
        from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/actionpack-2.3.5/lib/action_cont
roller.rb:34:in `<top (required)>'
        from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_s
upport/dependencies.rb:156:in `require'
        from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_s
upport/dependencies.rb:156:in `block in require'
        from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_s
upport/dependencies.rb:521:in `new_constants_in'
        from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.5/lib/active_s
upport/dependencies.rb:156:in `require'
        from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/commands/server.
rb:2:in `<top (required)>'
        from script/server:3:in `require'
        from script/server:3:in `<main>' </code>

I am not sure how to fix this, any advice would be great! thank you in
advance!

Hi Mike,

I got a similar error to this before.This happened when I was
tinkering with the environment.rb. If you've done this, you'll want to
revert everything back.

I haven't found a solution to fix this, so the best advice I can give
you is download Ruby 1.8.7 and redo the whole installation process as
well as your coding. You'll want to work in the Ruby 1.8.7 terminal so
the computer won't get confused about which Ruby version you're using.
It's not the best solution and far from ideal, but it's the only one I
have.

Wish you luck :slight_smile:
Anon_comp

Do you have the rack -v 1.0.1 gem installed?