script/plugin uhoh..... :O

Whenever i run script/plugin -list i get this--

script/plugin -list
/usr/lib/ruby/1.8/optparse.rb:1450:in `complete': invalid option: -
list (OptionParser::InvalidOption)
  from /usr/lib/ruby/1.8/optparse.rb:1448:in `catch'
  from /usr/lib/ruby/1.8/optparse.rb:1448:in `complete'
  from /usr/lib/ruby/1.8/optparse.rb:1287:in `parse_in_order'
  from /usr/lib/ruby/1.8/optparse.rb:1254:in `catch'
  from /usr/lib/ruby/1.8/optparse.rb:1254:in `parse_in_order'
  from /usr/lib/ruby/1.8/optparse.rb:1248:in `order!'
  from /usr/lib/ruby/1.8/optparse.rb:1339:in `permute!'
  from /usr/lib/ruby/1.8/optparse.rb:1360:in `parse!'
  from /home/david/.gem/ruby/1.8/gems/rails-2.3.5/lib/commands/
plugin.rb:513:in `parse!'
  from /home/david/.gem/ruby/1.8/gems/rails-2.3.5/lib/commands/
plugin.rb:534:in `parse!'
  from /home/david/.gem/ruby/1.8/gems/rails-2.3.5/lib/commands/
plugin.rb:968
  from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
  from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `require'
  from script/plugin:3

happened to any of you guys? whats the problem? Thanks