problem with script/plugin install

Whenever I try to install a plugin I get the following error:

e:/apps/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.1/lib/
active_support/dependencies.rb:422:in `remove_const': cannot
remove Object::OPT_TABLE (NameError)
        from e:/apps/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.1/
lib/active_support/dependencies.rb:422:in `send'
        from e:/apps/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.1/
lib/active_support/dependencies.rb:422:in `remove_c
onstant'
        from e:/apps/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.1/
lib/active_support/dependencies.rb:368:in `new_cons
tants_in'
        from e:/apps/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.1/
lib/active_support/dependencies.rb:368:in `each'
        from e:/apps/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.1/
lib/active_support/dependencies.rb:368:in `new_cons
tants_in'
        from e:/apps/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.1/
lib/active_support/dependencies.rb:495:in `require'

        from script/plugin:3

I would be grateful if somebody could shed some light.
Thanks
George