Running a rails project of 2.3.5 on rails 3.2.6

I have been trying to upgrade the project using the method on several blogs but failed to do so as the first command to install the plugin itself fails. Following is the error I get,

sumit@sumit:~/Downloads/railscasts-198-edit-multiple-individually-02eb1c8/store$ ruby script/plugin install git://github.com/rails/rails_upgrade.git
/usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:55:in gem_original_require': no such file to load -- initializer (LoadError) from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:55:in require’
from ./script/…/config/boot.rb:55:in load_initializer' from ./script/../config/boot.rb:38:in run’
from ./script/…/config/boot.rb:11:in boot!' from ./script/../config/boot.rb:110 from script/plugin:2:in require’
from script/plugin:2