rubygem 1.3.7 install problem

hi i am trying to install rubygem 1.3.7 on my linux system, i am using ruby 1.9.2p0, when i try to install rubygem i get the following error:

/opt/rubygems-1.3.7/lib/rubygems/source_index.rb:68:in `installed_spec_directories': undefined method `path' for Gem:Module (NoMethodError)
  from /opt/rubygems-1.3.7/lib/rubygems/source_index.rb:58:in `from_installed_gems'
  from /opt/rubygems-1.3.7/lib/rubygems.rb:883:in `source_index'
  from /opt/rubygems-1.3.7/lib/rubygems/gem_path_searcher.rb:81:in `init_gemspecs'
  from /opt/rubygems-1.3.7/lib/rubygems/gem_path_searcher.rb:13:in `initialize'
  from /opt/rubygems-1.3.7/lib/rubygems.rb:841:in `new'
  from /opt/rubygems-1.3.7/lib/rubygems.rb:841:in `block in searcher'
  from <internal:prelude>:10:in `synchronize'
  from /opt/rubygems-1.3.7/lib/rubygems.rb:840:in `searcher'
  from /opt/rubygems-1.3.7/lib/rubygems.rb:479:in `find_files'
  from /opt/rubygems-1.3.7/lib/rubygems.rb:983:in `load_plugins'
  from /opt/rubygems-1.3.7/lib/rubygems.rb:1139:in `<top (required)>'
  from <internal:lib/rubygems/custom_require>:29:in `require'
  from setup.rb:24:in `<main>'

You shouldn't need to install rubygem, since it is included as part of the
standard library since 1.9.

Dan

if i do that i see 2 errors when i try to install rails 3

22 gems installed
Installing ri documentation for activesupport-3.0.0...
Installing ri documentation for builder-2.1.2...
ERROR: While generating documentation for builder-2.1.2
... MESSAGE: Unhandled special: Special: type=17, text="<!-- HI -->"
... RDOC args: --ri --op
/usr/local/lib/ruby/gems/1.8/doc/builder-2.1.2/ri --title Builder --
Easy XML Building --main README --line-numbers --quiet lib CHANGES
Rakefile README doc/releases/builder-1.2.4.rdoc
doc/releases/builder-2.0.0.rdoc doc/releases/builder-2.1.1.rdoc
--title builder-2.1.2 Documentation
(continuing with the rest of the installation)
Installing ri documentation for i18n-0.4.1...

and the other error

Installing ri documentation for rails-3.0.0...
File not found: lib

ignore my previous post, i just built ruby 1.9.2-p0 from source and
when i type gem -v i get the following error ??? how do I get rubygems
working so I can install rails 3, etc.

yadav@vision:~$ ruby -v
ruby 1.9.2p0 (2010-08-18 revision 29036) [i686-linux]

yadav@vision:~$ uname -a
Linux vision 2.6.32-24-generic #42-Ubuntu SMP Fri Aug 20 14:24:04 UTC
2010 i686 GNU/Linux

yadav@vision:~$ gem -v
/usr/local/lib/ruby/site_ruby/1.9.1/rubygems/source_index.rb:68:in
`installed_spec_directories': undefined method `path' for Gem:Module
(NoMethodError)
  from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems/source_index.rb:
58:in `from_installed_gems'
  from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems.rb:881:in
`source_index'
  from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems/
gem_path_searcher.rb:81:in `init_gemspecs'
  from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems/
gem_path_searcher.rb:13:in `initialize'
  from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems.rb:839:in `new'
  from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems.rb:839:in `block in
searcher'
  from <internal:prelude>:10:in `synchronize'
  from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems.rb:838:in
`searcher'
  from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems.rb:478:in
`find_files'
  from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems.rb:1103:in `<top
(required)>'
  from <internal:lib/rubygems/custom_require>:29:in `require'
  from <internal:lib/rubygems/custom_require>:29:in `require'
  from /usr/local/bin/gem:8:in `<main>'

Any updates on this?
I just compiled ruby 1.9.2 from source and tried to install rubygem
1.3.7 (I did check if it was already installed on not) but it errors
out. Does anyone know what is the problem and how to fix it?

DT07-13:/home/rwaadmin/Desktop/rubygems-1.3.7# ruby -v
ruby 1.9.2p0 (2010-08-18 revision 29036) [i686-linux]

DT07-13:/home/rwaadmin/Desktop/rubygems-1.3.7# gem -v
bash: gem: command not found

DT07-13:/home/rwaadmin/Desktop/rubygems-1.3.7# ruby setup.rb
/home/rwaadmin/Desktop/rubygems-1.3.7/lib/rubygems/source_index.rb:68:in
`installed_spec_directories': undefined method `path' for Gem:Module
(NoMethodError)
  from
/home/rwaadmin/Desktop/rubygems-1.3.7/lib/rubygems/source_index.rb:58:in
`from_installed_gems'
  from /home/rwaadmin/Desktop/rubygems-1.3.7/lib/rubygems.rb:883:in
`source_index'
  from
/home/rwaadmin/Desktop/rubygems-1.3.7/lib/rubygems/gem_path_searcher.rb:81:in
`init_gemspecs'
  from
/home/rwaadmin/Desktop/rubygems-1.3.7/lib/rubygems/gem_path_searcher.rb:13:in
`initialize'
  from /home/rwaadmin/Desktop/rubygems-1.3.7/lib/rubygems.rb:841:in
`new'
  from /home/rwaadmin/Desktop/rubygems-1.3.7/lib/rubygems.rb:841:in
`block in searcher'
  from <internal:prelude>:10:in `synchronize'
  from /home/rwaadmin/Desktop/rubygems-1.3.7/lib/rubygems.rb:840:in
`searcher'
  from /home/rwaadmin/Desktop/rubygems-1.3.7/lib/rubygems.rb:479:in
`find_files'
  from /home/rwaadmin/Desktop/rubygems-1.3.7/lib/rubygems.rb:983:in
`load_plugins'
  from /home/rwaadmin/Desktop/rubygems-1.3.7/lib/rubygems.rb:1139:in
`<top (required)>'
  from <internal:lib/rubygems/custom_require>:29:in `require'
  from <internal:lib/rubygems/custom_require>:29:in `require'
  from setup.rb:24:in `<main>'

Thanks a lot in advance!

Kind regards,
DBeer

Dmitriy B. wrote in post #960995:

Any updates on this?
I just compiled ruby 1.9.2 from source and tried to install rubygem
1.3.7 (I did check if it was already installed on not) but it errors
out. Does anyone know what is the problem and how to fix it?

I am having the same problem. I am on an ubuntu system: Ubuntu 10.04 LTS
- the Lucid Lynx . I downloaded and installed ruby 1.9.2, and ruby -v:
ruby 1.9.2p0 (2010-08-18 revision 29036) [i686-linux]

gem -v is 1.3.7.

But when I try to run gem install ...

gem install rails -v 3.0.2
ERROR: Loading command: install (LoadError)
    no such file to load -- zlib
ERROR: While executing gem ... (NameError)
    uninitialized constant Gem::Commands::InstallCommand

So I downloaded gem1.3.7 and when I run
ruby setup.rb

I get:
ruby setup.rb --help
/home/julian/Work/ruby/rubygems-1.3.7/lib/rubygems/source_index.rb:68:in
`installed_spec_directories': undefined method `path' for Gem:Module
(NoMethodError)
  from
/home/julian/Work/ruby/rubygems-1.3.7/lib/rubygems/source_index.rb:58:in
`from_installed_gems'
  from /home/julian/Work/ruby/rubygems-1.3.7/lib/rubygems.rb:883:in
`source_index'
  from
/home/julian/Work/ruby/rubygems-1.3.7/lib/rubygems/gem_path_searcher.rb:81:in
`init_gemspecs'
  from
/home/julian/Work/ruby/rubygems-1.3.7/lib/rubygems/gem_path_searcher.rb:13:in
`initialize'
  from /home/julian/Work/ruby/rubygems-1.3.7/lib/rubygems.rb:841:in
`new'
  from /home/julian/Work/ruby/rubygems-1.3.7/lib/rubygems.rb:841:in
`block in searcher'
  from <internal:prelude>:10:in `synchronize'
  from /home/julian/Work/ruby/rubygems-1.3.7/lib/rubygems.rb:840:in
`searcher'
  from /home/julian/Work/ruby/rubygems-1.3.7/lib/rubygems.rb:479:in
`find_files'
  from /home/julian/Work/ruby/rubygems-1.3.7/lib/rubygems.rb:983:in
`load_plugins'
  from /home/julian/Work/ruby/rubygems-1.3.7/lib/rubygems.rb:1139:in
`<top (required)>'
  from <internal:lib/rubygems/custom_require>:29:in `require'
  from <internal:lib/rubygems/custom_require>:29:in `require'
  from setup.rb:24:in `<main>'

Julian G. wrote in post #963097:

I am having the same problem. I am on an ubuntu system: Ubuntu 10.04 LTS
- the Lucid Lynx . I downloaded and installed ruby 1.9.2, and ruby -v:
ruby 1.9.2p0 (2010-08-18 revision 29036) [i686-linux]

gem -v is 1.3.7.

But when I try to run gem install ...

gem install rails -v 3.0.2
ERROR: Loading command: install (LoadError)
    no such file to load -- zlib
ERROR: While executing gem ... (NameError)
    uninitialized constant Gem::Commands::InstallCommand

Julian, it appears you already have gem installed, so you don't need to
compile it from source. What you are missing though is a zlib library.
What you need to do is cd into your ruby 1.9.2 source code dir then into
ext/zlib (so for me it'd look like
/home/username/Desktop/ruby-1.9.2-p0/ext/zlib/).
Then run:
ruby extconf.rb
make
make install
Then you should be able to run
gem install rails

Hope that helps.

Thanks Dmitriy. That solved my problem.