'ruby script/server' fails. 'No such file to load' Not sure what the issue is.

I installed Ruby, RubyGems and Rails with no problems. When I issue
the 'ruby script/server' command it gives me the following output and
fails. Can someone tell me what might be my problem? My distro is
CentOS 5.3 just in case that helps any.

ruby script/server
=> Booting WEBrick
=> Rails 2.3.2 application starting on http://0.0.0.0:3000
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.2/lib/initializer.rb:
269:in `require_frameworks': no such file to load -- openssl
(RuntimeError)
        from /usr/local/lib/ruby/gems/1.8/gems/rails-2.3.2/lib/
initializer.rb:134:in `process'
        from /usr/local/lib/ruby/gems/1.8/gems/rails-2.3.2/lib/
initializer.rb:113:in `send'
        from /usr/local/lib/ruby/gems/1.8/gems/rails-2.3.2/lib/
initializer.rb:113:in `run'
        from /home/earth2j/myRailsApp/config/environment.rb:9
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:31:in `gem_original_require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:31:in `require'
        from /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/
active_support/dependencies.rb:156:in `require'
        from /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/
active_support/dependencies.rb:521:in `new_constants_in'
        from /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/
active_support/dependencies.rb:156:in `require'
        from /usr/local/lib/ruby/gems/1.8/gems/rails-2.3.2/lib/
commands/server.rb:84
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:31:in `gem_original_require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:31:in `require'
        from script/server:3

Looks like openssl isn’t set up correctly.

“no such file to load – openssl”

I haven’t used CentOS, but this blog post might help: http://www.odindev.com/ruby-errors-centos-52

"I used yum and downloaded the openssl-devel package and
dependancies but still was getting the error. To fix, you have to
recompile from scratch OR just do:

cd /path_to_ruby_src/ext/openssl/

ruby extconf.rb

make

make install"

Christopher Warren
christopher.warren@gmail.com

612.424.9880