Ruby OpenSSL issues

I am trying to update ruby on my mac and keep getting an issue with openssl. I have this posted on StackOverflow so if you can answer it you can get some points over there too.

Using rvm I upgraded my ruby to 1.9.3-p392, also added 2.0.0, anytime I try to use this version when I run my bundle command I get this error.

Could not load OpenSSL.

You must recompile Ruby with OpenSSL support or change the sources in your Gemfile from ‘https’ to ‘http’. Instructions for compiling with OpenSSL using RVM are

available at rvm.io/packages/openssl.

I have followed several different instructions on how to fix this. I have tried removing the version and installing it with the rvm options

–with-openssl-dir=$HOME/.rvm/usr

I have installed OpenSSL with rvm, and macports. Both have not helped the problem. I even changed the file location of the ssl cert using this:

export SSL_CERT_FILE=/Users/DarkLord/.rvm/usr/ssl/cert.pem

$ openssl version

OpenSSL 1.0.1e 11 Feb 2013

$ which openssl

/opt/local/bin/openssl

check my post - and build your ruby as I described

http://tom.meinlschmidt.org/2012/05/07/ruby-1-9-3-seg-fault-fix/

tom