RMagick on Mac OS X - weird error

Hey,

I'm trying to install RMagick on Leopard, and I've already installed
ImageMagick. Here's the version I have:
$ convert -version
Version: ImageMagick 6.3.9 03/17/08 Q8 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2008 ImageMagick Studio LLC

I downloaded RMagick-1.15.13.tar.gz from this page:
http://rubyforge.org/frs/?group_id=12&release_id=18732

There are some simple instructions once you extract RMagick.
$ ./configure <configuration options>
$ make
($ su)
$ make install
(optionally)
$ make clean

I ran "./configure" and everything seemed to run fine.

Then I ran "make" and after a bit, got these weird errors:
rmimage.c: In function ‘Image_delay’:
rmimage.c:3569: error: ‘C_unsigned’ undeclared (first use in this
function)
rmimage.c:3569: error: (Each undeclared identifier is reported only once
rmimage.c:3569: error: for each function it appears in.)
rmimage.c:3569: error: syntax error before ‘long_to_R_unsigned’

I've searched for solutions to this, but haven't found anything. Can
anyone help? rmagick has been driving me bonkers.

I'm trying to install RMagick on Leopard, and I've already installed
ImageMagick. Here's the version I have:
$ convert -version
Version: ImageMagick 6.3.9 03/17/08 Q8 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2008 ImageMagick Studio LLC

I downloaded RMagick-1.15.13.tar.gz from this page:
http://rubyforge.org/frs/?group_id=12&release_id=18732

Why not download 2.2.2?

I'm on leopard...

$ convert -version
Version: ImageMagick 6.3.9 03/12/08 Q16 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2008 ImageMagick Studio LLC

$ gem search rmagick

*** LOCAL GEMS ***
rmagick (2.2.2)

I just did "sudo gem install rmagick" though....

I tried to use rmagick-1.15.13 just because I had it working on another
computer.

But anyhoo, if I try
sudo gem install rmagick

I get this error:
Building native extensions. This could take a while...
ERROR: Error installing rmagick:
ERROR: Failed to build gem native extension.

and then these errors at the end:
rmimage.c:3181: error: 'C_unsigned' undeclared (first use in this
function)
rmimage.c:3181: error: (Each undeclared identifier is reported only once
rmimage.c:3181: error: for each function it appears in.)
rmimage.c:3181: error: syntax error before 'long_to_R_unsigned'

Does anyone know why I can't seem to install rmagick?

Do you have Xcode installed?

I am pretty sure Xcode is installed -- doing "locate xcode" yields a lot
of results.

I can install all other gems, but not rmagick. I already have
ImageMagick installed, too. Any ideas on what the problem could be?

I tested ImageMagick by converting a .gif to a .jpg, and it worked
great.

My only problem seems to be rmagick. Whenever I try
"sudo gem install rmagick"
I get
Building native extensions. This could take a while...
ERROR: Error installing rmagick:
ERROR: Failed to build gem native extension.

Do I need to specify some options when I install rmagick?

Welp, looks like I already have X11 on the computer:

$ X -version
TransformProcessType: Success
X11.app starting:
X.org Release 7.2
X.Org Xquartz X Server 1.3.0-apple5
Build Date: 20080109

Also, I already have XCode:
version 3.0

So those seem fine. Plus I have ImageMagick installed. What more do I
need to do to be able to install RMagick??

installing RMagick is always a tricky one. Recommend checking out this
installer script: http://rubyforge.org/frs/?group_id=12&release_id=16101

ESPNDev@gmail.com wrote:

installing RMagick is always a tricky one. Recommend checking out this
installer script: http://rubyforge.org/frs/?group_id=12&release_id=16101

It definitely is a tricky one. I've already tried that, to no avail.
My guess now is that I have more than one version of ImageMagick
installed.

$ convert -version
Version: ImageMagick 6.3.9 03/17/08 Q8 http://www.imagemagick.org
Copyright: Copyright (C) 1999-2008 ImageMagick Studio LLC

But when I do "locate ImageMagick" it just finds a bunch of
ImageMagick-6.3.2 files, no ImageMagick-6.3.9 files at all. And when I
go to look at those ImageMagick-6.3.2 files, they aren't there.

Does anyone have some good advice on how to completely remove
ImageMagick? It's like a week that I can't kill...