RMagick, ImageMagick, Passenger and Dreamhost

I need to use the newest version of RMagick, so i did everything as
they say on this wiki: http://wiki.dreamhost.com/index.php/RMagick

But, my Rails app isn't working, here is the error:

This installation of RMagick was configured with ImageMagick 6.5.1 but
ImageMagick 6.0.6 is in use.

I tried to set the environment variable: LD_LIBRARY_PATH... but no
success...
I've read a lot of people with the same problem, but i couldn't find
the solution.
I guess the problem is to set a environment variable in passenger.
Does anybody can help me?

Thanks a lot.

It looks like you need to check the following:

1) Did you install your own version of ImageMagick in your local
directory? Both of the following two Unix commands should give the
same response. NOTE: YOUR_HOME should be the path to your home
directory. i.e.: I see /Users/rick/local/bin/Magick-config on my
system.

$ ls ~/local/bin/Magick-config
YOUR_HOME/local/bin/Magick-config
$ which Magick-config
YOUR_HOME/local/bin/Magick-config
$

If the first command fails, you need to re-install ImageMagick paying
attention to the instructions for setting "--prefix=" in the
configuration step. After the re-install of ImageMagick you'll need
to reinstall RMagick.

If the first command succeeds but the second fails, you need to add
the RMagick export settings to your shell's runtime command file.

Shell RC File
bash ~/.profile or ~/.bashrc
csh ~/.login or ~/.cshrc
tcsh ~/.login or ~/.tcshrc
ksh ~/.profile or ~/.kshrc
sh ~/.profile

Edit your RC file and add the following lines:

$ export PATH=$HOME/local/bin:$PATH
$ export LDFLAGS=-L/$HOME/local/lib
$ export CPPFLAGS=-I/$HOME/local/include
$ export LD_RUN_PATH=$HOME/local/lib

Log out and back in and retry the "ls ~/local/bin/Magick-config" and
"which Magick-config". The results of both commands should now be
identical. If you check the file (more ~/local/bin/Magick-config) you
should see the prefix, exec_prefix, libdir, and included_dir as
pointing at your home directory. RMagick should work now.

Hey Rick,
Thanks for answer..
Yes i did compile my own ImageMagick and installed RMagick.
Everything is like you said. But still no success...

Same error message: This installation of RMagick was configured with
ImageMagick 6.5.1 but ImageMagick 6.0.6 is in use.

I think it's not possible to set or pass environment variables to
passenger, apache...

I'm trying this for almost a week...
Please help me... if somebody uses Dreamhost or any similar shared
hosting and did this please tell me how...

So far... thanks for the help.
Daniel

And also,
If i do this:

ruby -r RMagick -e"puts Magick::Long_version"

It shows the old version of ImageMagick

And if i set config.cache_classes to false on my environments/
production.rb everithing works fine...
but slowly...

May be the solution is to reset this cache_classes?

Thanks everybody.
Daniel

Nobody??? Please...

did you perform ldconfig?

did you try to find out where rmagick libs are?

you can try to remove /usr/local/ruby/gem/1.8/cache/rmagick-*.gem

(u have to correct the path)

tom

Daniel2Surf wrote:

I don't have root access. It's a shared host. that's the main
problem...

I had the same problem on Ubuntu, and

$sudo apt-get install librmagick-ruby1.8

did the trick for me. Hope this helps anybody.