rake error

/usr/bin/rake:9:in `require': no such file to load -- rubygems
(LoadError)
        from /usr/bin/rake:9

I got this error when following an online guide in rails, the command
I had to type in was # rake db:create.. after I typed in the command I
got the above error. It's almost 2 days that I'm searching for a
solution to this. But in vain,

Can anyone help me out btw I'm a rookie in RoR

Quoting Meow san <meowsanforever@hotmail.com>:

/usr/bin/rake:9:in `require': no such file to load -- rubygems
(LoadError)
        from /usr/bin/rake:9

I got this error when following an online guide in rails, the command
I had to type in was # rake db:create.. after I typed in the command I
got the above error. It's almost 2 days that I'm searching for a
solution to this. But in vain,

Is rubygems installed? At the command line, type:

gem list --local rubygems

If nothing listed, type "gem install rubygems", preferably as root.

HTH,
  Jeffrey

Hello,

/usr/bin/rake:9:in `require’: no such file to load – rubygems

(LoadError)

    from /usr/bin/rake:9

I got this error when following an online guide in rails, the command

I had to type in was # rake db:create… after I typed in the command I

got the above error. It’s almost 2 days that I’m searching for a

solution to this. But in vain,

It seem that your rubygems hasn’t been installed on your system.

You can install it from repository. You cannot install rubygems by

itself (gem install …).

gem is Ruby’s packages manager.

Can anyone help me out btw I’m a rookie in RoR

Best regards,

Duong Quang Ha