Railstutorial.org - Integration Test breaking on webrat visit root_path

Hi

I'm working through the rails tutorial at railstutorial.org -
Specifically the video.

After a bumpy start with various gem versions - things were working
well. That is until I hit the 'integration test' section. (NOTE:
Section 5.5 / listing 5.33 in the web tutorial)

As instructed in the video I added this to layout_links_spec.rb ...

  it "should have the right links on the layout" do
   visit root_path
   response.should have_selector('title', :content => "Home")
  end

Now when I run the 'rspec spec/' - I get this error ...

  Failure/Error: response.should have_selector('title', :content =>
'Home')
  expected following output to contain a <title>Home</title> tag:
  <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://
www.w3.org/TR/REC-html40/loose.dtd"

Before adding this last spec - all my rspec tests worked - aka I was
'green'.

My current Gemfile contains ...

  group :development do
   gem 'rspec-rails', '2.3.0'
  end

  group :test do
   gem 'rspec', '2.3.0'
   gem 'webrat', '0.7.1'
   gem 'spork', '0.8.4'
  end

as recommended by the railstutorial site ->
http://railstutorial.org/chapters/updating-showing-and-deleting-users#code:final_gemfile

Any help would be extremely appreciated. I really want to embrace to
BDD / TDD - but these gem 'issues' are really frustrating.

Thanks
Dave