Rails OSX Tiger RMagick Bus Error Abort trap

Hi;

I am using a PowerBook G4 with:
OSX Tiger version 10.4.7; Rubygems 0.9; Rails 1.1.6; RMagic 1.13.0

I have Ruby and friends installed at /usr/local/...
just as described in:
http://hivelogic.com/articles/2005/12/01/ruby_rails_lighttpd_mysql_tiger

then installed RMagick as descibed in:
http://hivelogic.com/articles/2006/06/10/rmagick_os_x

Then installed file_column and the full Rails environment worked fine
for about four weeks. I could do script/console under iterm and get into the
development environment.

Then, I had to update Quicksilver, Rubygems and Rails; after
that, I can't access script/console.

If I do script/console under my Rails app dir in iterm, I get this:

PBG4:~/Rails/app vr_mex$ script/console
Loading development environment.
/usr/local/lib/ruby/gems/1.8/gems/rmagick-1.13.0/lib/RMagick.bundle:
[BUG] Bus Error
ruby 1.8.4 (2005-12-24) [powerpc-darwin8.7.0]

Abort trap

So then I deleted all RMagick using: uninstall-RMagick.rb and went to
install RMagick again via the same method:
http://hivelogic.com/articles/2006/06/10/rmagick_os_x

I got nowhere same error when I do script/console under my Rails app
dir; so then I thought it had to do with file_column, so I went
and tried it with acts_as_attachment via doing th sample Rails app in:
http://weblog.techno-weenie.net/articles/acts_as_attachment

For acts_as_attachment example to work, I had to install
acts_as_attachment-1.1.6 that I got from here:
http://svn.techno-weenie.net/projects/plugins/tags/acts_as_attachment

Well I got acts_as_attachment to work fine, but when I went into iterm
and tried script/console, I got the same error as before; so clearly it is not a
problem with acts_as_attachment or file_column

Then from iterm I did this:
PBG4:~/Rails/app vr_mex$ ruby -rrubygems -e "require 'RMagick'; puts Magick::Long_version;"
This is RMagick 1.13.0 ($Date: 2006/06/26 23:32:37 $) Copyright (C) 2006 by Timothy P. Hunter
Built with ImageMagick 6.2.8 09/22/06 Q16 http://www.imagemagick.org
Built for ruby 1.8.4 (2005-12-24) [powerpc-darwin8.7.0]
Web page: http://rmagick.rubyforge.org
Email: rmagick@rubyforge.org

If i do this :
PBG4:~/Rails/app vr_mex$ which ruby
/usr/local/bin/ruby

So I reinstalled Ruby and friends again at /usr/local/...
just as described in:
http://hivelogic.com/articles/2005/12/01/ruby_rails_lighttpd_mysql_tiger

then reinstalled RMagick again as descibed in:
http://hivelogic.com/articles/2006/06/10/rmagick_os_x

And still getting the same error, can't get script/console to work.

I need to have script/console access when using RMagic under Rails.

Please Help

try building rmagick from source. Any problems installing rmagic will be shown this way. By installing by source, I solved an rmagick problem I was stumbling on for over a week.

The only way I got it to work was to remove all the Hivelogic steps completely, download DarwinPorts and then install graphicsMagick instead of ImageMagick. Worked like a charm.

PGP.sig (186 Bytes)

I've been using rmagick with rails on OS X. I followed these
directions to install:
http://rmagick.rubyforge.org/install-osx.html
Worked like a charm!

Sarah

Thanks Pete and Sarah;

My main concern is if I go the DarwinPorts road,
I have all installed in /usr/local and DarwinPorts installs all
in /opt/... so my question would be :
is anyone of you using a mixed environment say having
Ruby and others in /usr/local and just the Imagemagick stuff in
/opt/...?

I know some people are using all under /usr/local that is the way I
would
prefer to go...

Sarah Mei wrote:

I have all (RMagic, Ruby, gem, rails, etc.) under /opt with Darwinports. It seemed less complicated that way. sudo port install “whatever” and it works.

Vish

Thanks Vishnu,

Wish I could do that but I do have some other apps that have to be in
/usr/local/... and that do not have DarwinPorts support...

Guys, any other suggestions as to how to install in /usr/local/... ?
Anyone else has had this problem and solved it lately under
/usr/local/... ?

Vishnu Gopal wrote:

Finally I fixed this problem.
now all works under /usr/local/...

I followed this link's instructions:
http://blog.labratz.net/articles/2006/10/10/really-truly-getting-imagemagick-rmagick-working-on-osx-from-source-without-using-macports-darwinports-or-fink

and applied the shell script:
http://blog.labratz.net/files/rmagick_imagemagick_redo_osx.sh