rails gem error:i have a new rails application with the new controller called test,and i have tried to call the method inside the test controller,it gives me error like below:

rubygems/custom_require.rb:31:in `require'
    script/server:3
/!\ FAILSAFE /!\ Thu May 20 11:15:33 +0530 2010
  Status: 500 Internal Server Error
  no such file to load -- sqlite3
    c:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_origina
l_require'
    c:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
    c:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/depend
encies.rb:156:in `require'
    c:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/depend
encies.rb:521:in `new_constants_in'
    c:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/depend
encies.rb:156:in `require'
    c:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/core_e
xt/kernel/requires.rb:7:in `require_library_or_gem'
    c:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/core_e
xt/kernel/reporting.rb:11:in `silence_warnings'
    c:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/core_e
xt/kernel/requires.rb:5:in `require_library_or_gem'
    c:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/
active_record/connecti
on_adapters/sqlite3_adapter.rb:10:in `sqlite3_connection'
    c:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/
active_record/connecti
on_adapters/abstract/connection_pool.rb:223:in `send'
    c:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/
active_record/connecti
on_adapters/abstract/connection_pool.rb:223:in `new_connection'
    c:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/
active_record/connecti
on_adapters/abstract/connection_pool.rb:245:in
`checkout_new_connection'
    c:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/
active_record/connecti
on_adapters/abstract/connection_pool.rb:188:in `checkout'
    c:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/
active_record/connecti
on_adapters/abstract/connection_pool.rb:184:in `loop'
    c:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/
active_record/connecti
on_adapters/abstract/connection_pool.rb:184:in `checkout'
    c:/Ruby/lib/ruby/1.8/monitor.rb:242:in `synchronize'
    c:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/
active_record/connecti
on_adapters/abstract/connection_pool.rb:183:in `checkout'
    c:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/
active_record/connecti
on_adapters/abstract/connection_pool.rb:98:in `connection'
    c:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/
active_record/connecti
on_adapters/abstract/connection_pool.rb:326:in `retrieve_connection'
    c:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/
active_record/connecti
on_adapters/abstract/connection_specification.rb:123:in
`retrieve_connection'
    c:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/
active_record/connecti
on_adapters/abstract/connection_specification.rb:115:in `connection'
    c:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/
active_record/query_ca
che.rb:9:in `cache'
    c:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/
active_record/query_ca
che.rb:28:in `call'
    c:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.5/lib/
active_record/connecti
on_adapters/abstract/connection_pool.rb:361:in `call'
    c:/Ruby/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/
action_controller/string
_coercion.rb:25:in `call'
    c:/Ruby/lib/ruby/gems/1.8/gems/rack-1.0.1/lib/rack/head.rb:9:in
`call'
    c:/Ruby/lib/ruby/gems/1.8/gems/rack-1.0.1/lib/rack/
methodoverride.rb:24:in `
call'
    c:/Ruby/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/
action_controller/params
_parser.rb:15:in `call'
    c:/Ruby/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/
action_controller/sessio
n/cookie_store.rb:93:in `call'
    c:/Ruby/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/
action_controller/failsa
fe.rb:26:in `call'
    c:/Ruby/lib/ruby/gems/1.8/gems/rack-1.0.1/lib/rack/lock.rb:11:in
`call'
    c:/Ruby/lib/ruby/gems/1.8/gems/rack-1.0.1/lib/rack/lock.rb:11:in
`synchroniz
e'
    c:/Ruby/lib/ruby/gems/1.8/gems/rack-1.0.1/lib/rack/lock.rb:11:in
`call'
    c:/Ruby/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/
action_controller/dispat
cher.rb:114:in `call'
    c:/Ruby/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/
action_controller/reload
er.rb:34:in `run'
    c:/Ruby/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/
action_controller/dispat
cher.rb:108:in `call'
    c:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/rails/rack/
static.rb:31:in `c
all'
    c:/Ruby/lib/ruby/gems/1.8/gems/rack-1.0.1/lib/rack/urlmap.rb:46:in
`call'
    c:/Ruby/lib/ruby/gems/1.8/gems/rack-1.0.1/lib/rack/urlmap.rb:40:in
`each'
    c:/Ruby/lib/ruby/gems/1.8/gems/rack-1.0.1/lib/rack/urlmap.rb:40:in
`call'
    c:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/rails/rack/
log_tailer.rb:17:i
n `call'
    c:/Ruby/lib/ruby/gems/1.8/gems/rack-1.0.1/lib/rack/
content_length.rb:13:in `
call'
    c:/Ruby/lib/ruby/gems/1.8/gems/rack-1.0.1/lib/rack/chunked.rb:
15:in `call'
    c:/Ruby/lib/ruby/gems/1.8/gems/rack-1.0.1/lib/rack/handler/
mongrel.rb:64:in
`process'
    c:/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/
mongrel.rb:1
59:in `process_client'
    c:/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/
mongrel.rb:1
58:in `each'
    c:/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/
mongrel.rb:1
58:in `process_client'
    c:/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/
mongrel.rb:2
85:in `run'
    c:/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/
mongrel.rb:2
85:in `initialize'
    c:/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/
mongrel.rb:2
85:in `new'
    c:/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/
mongrel.rb:2
85:in `run'
    c:/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/
mongrel.rb:2
68:in `initialize'
    c:/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/
mongrel.rb:2
68:in `new'
    c:/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mswin32-60/lib/
mongrel.rb:2
68:in `run'
    c:/Ruby/lib/ruby/gems/1.8/gems/rack-1.0.1/lib/rack/handler/
mongrel.rb:34:in
`run'
    c:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/commands/server.rb:
111
    c:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_origina
l_require'
    c:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
    script/server:3

what was the error ,what should do if i am going wrong anywhere in
this segment .........

The first line of the error is giving you the most important information.
It doesn't look like you have sqlite (or the gems to access it from
Rails) installed on your platform.

A bit of Googling for "<my os> Rails Sqlite install" should help you.