Rails::Plugin::Dependencies in rails-2.2

i got "Rails::Plugin::Dependencies" error after updating my gem version
to rails -2.2.0

any idea?

Not without more details.

Fred

Frederick Cheung wrote:

i got "Rails::Plugin::Dependencies" error after updating my gem version
to rails -2.2.0

any idea?

Not without more details.

Fred

already i was using rails-2.0.2
my project working fine
just now i am updating rails gems to rails 2.2.0
this is the error

C:/projects/forum>rake db:migrate --trace
(in c:/projects/forum)
** Invoke db:migrate (first_time)
** Invoke environment (first_time)
** Execute environment
rake aborted!
uninitialized constant Rails::Plugin::Dependencies
c:/projects/forum/vendor/rails/activesupport/lib/active_support/dependencies.rb:102:in
`const_missing'
c:/projects/forum/vendor/plugins/svn/init.rb:7:in `evaluate_init_rb'
c:/projects/forum/vendor/plugins/svn/init.rb:6:in `each'
c:/projects/forum/vendor/plugins/svn/init.rb:6:in `evaluate_init_rb'
c:/projects/forum/config/../vendor/rails/railties/lib/rails/plugin.rb:103:in
`evaluate_init_rb'
c:/projects/forum/vendor/rails/activesupport/lib/active_support/core_ext/kernel/reporting.rb:11:in
`silence_warnings'
c:/projects/forum/config/../vendor/rails/railties/lib/rails/plugin.rb:99:in
`evaluate_init_rb'
c:/projects/forum/config/../vendor/rails/railties/lib/rails/plugin.rb:44:in
`load'
c:/projects/forum/config/../vendor/rails/railties/lib/rails/plugin/loader.rb:33:in
`load_plugins'
c:/projects/forum/config/../vendor/rails/railties/lib/rails/plugin/loader.rb:32:in
`each'
c:/projects/forum/config/../vendor/rails/railties/lib/rails/plugin/loader.rb:32:in
`load_plugins'
c:/projects/forum/config/../vendor/rails/railties/lib/initializer.rb:319:in
`load_plugins'
c:/projects/forum/config/../vendor/rails/railties/lib/initializer.rb:157:in
`process'
c:/projects/forum/config/../vendor/rails/railties/lib/initializer.rb:112:in
`send'
c:/projects/forum/config/../vendor/rails/railties/lib/initializer.rb:112:in
`run'
c:/projects/forum/config/environment.rb:13
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
c:/projects/forum/vendor/rails/activesupport/lib/active_support/dependencies.rb:148:in
`require'
c:/projects/forum/vendor/rails/activesupport/lib/active_support/dependencies.rb:507:in
`new_constants_in'
c:/projects/forum/vendor/rails/activesupport/lib/active_support/dependencies.rb:148:in
`require'
c:/projects/forum/vendor/rails/railties/lib/tasks/misc.rake:3
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:617:in `call'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:617:in `execute'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:612:in `each'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:612:in `execute'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:578:in
`invoke_with_call_chain'
c:/ruby/lib/ruby/1.8/monitor.rb:242:in `synchronize'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:571:in
`invoke_with_call_chain'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:588:in
`invoke_prerequisites'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:585:in `each'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:585:in
`invoke_prerequisites'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:577:in
`invoke_with_call_chain'
c:/ruby/lib/ruby/1.8/monitor.rb:242:in `synchronize'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:571:in
`invoke_with_call_chain'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:564:in `invoke'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2019:in
`invoke_task'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1997:in
`top_level'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1997:in `each'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1997:in
`top_level'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2036:in
`standard_exception_handling'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1991:in
`top_level'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1970:in `run'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2036:in
`standard_exception_handling'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1967:in `run'
c:/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/bin/rake:31
c:/ruby/bin/rake:19:in `load'
c:/ruby/bin/rake:19

C:/projects/forum>

i am trying to use beast (which named as svn in plugins)
init.rb

ActionView::Base.send :include, SavageBeast::AuthenticationSystem
ActionController::Base.send :include, SavageBeast::AuthenticationSystem

FIX for engines model reloading issue in development mode
if ENV['RAILS_ENV'] != 'production'
  load_paths.each do |path|
    Dependencies.load_once_paths.delete(path)
  end
end

i am trying to use beast (which named as svn in plugins)
init.rb

ActionView::Base.send :include, SavageBeast::AuthenticationSystem
ActionController::Base.send :include,
SavageBeast::AuthenticationSystem

FIX for engines model reloading issue in development mode
if ENV['RAILS_ENV'] != 'production'
load_paths.each do |path|
   Dependencies.load_once_paths.delete(path)
end
end

Dependencies is now ActiveSupport::Dependencies

Fred