Rails 7 console auto completion makes it unusable

Since I upgraded to Rails 7, whenever I type something on the rails console, I get a window with the possible auto completion possibilities.

That’s nice if it wasn’t that slow. Typing in characters is not that slow, but pressing the backspace key allow me on average to remove one character per second. If I press the backspace key more than that, it gets ignored. it is really annoying

Is there a way to disable auto completion ? Escape character does not let me close the completion box.

2 Likes

Had that same problem. Just do this:

echo 'IRB.conf[:USE_AUTOCOMPLETE] = false' >> ~/.irbrc
4 Likes

I ran into the same situation. The idea is nice but it’s just unusable. It also makes the terminal very jumpy and it’s easier to loose focus on the pointer. It gets even worse when I start a new string and paste a few thousand lines, it nearly crashes.