Rails 6 stripe - parser error rails-ujs

How do I fix this error? safari, macos, rails 6, ruby 2.7 - following a stripe checkout tutorial. thank you.

Screenshot 2021-10-28 at 14.37.41

It seems its not an error. moving on: does it make sense to ‘freeze’ all the packages at one version number (in the Gemfile) after creating a new rails app/site? Do people do that to avoid being bitten in the butt by updates?

Screenshot 2021-11-02 at 14.20.26

so far so good though, its all working