Rails 3 Error:uninitialized constant ActiveResource::Base

I'v just install rails3 for try it out. I was following "getting started guide": rm public/index.html, change routes...

and then i try to open page i'v got an error.

OS: ubunto 10.04 Rails info: dpush@dpush-desktop:~/rails_proj/blog/public$ ruby -v ruby 1.8.7 (2010-01-10 patchlevel 249) [x86_64-linux] dpush@dpush-desktop:~/rails_proj/blog/public$ rails -v Rails 3.0.0.beta3 dpush@dpush-desktop:~/rails_proj/blog/public$ gem list

*** LOCAL GEMS ***

abstract (1.0.0) actionmailer (3.0.0.beta3) actionpack (3.0.0.beta3) activemodel (3.0.0.beta3) activerecord (3.0.0.beta3) activeresource (3.0.0.beta3) activesupport (3.0.0.beta3, 2.3.6) arel (0.3.3) builder (2.1.2) bundler (0.9.25) erubis (2.6.5) i18n (0.3.7) mail (2.2.1) memcache-client (1.8.3) mime-types (1.16) polyglot (0.3.1) rack (1.1.0) rack-mount (0.6.3) rack-test (0.5.3) rails (3.0.0.beta3) railties (3.0.0.beta3) rake (0.8.7) text-format (1.0.0) text-hyphen (1.0.0) thor (0.13.6) treetop (1.4.5) tzinfo (0.3.20)

ERROR NameError: uninitialized constant ActiveResource::Base   /usr/lib/ruby/gems/1.8/gems/activeresource-3.0.0.beta3/lib/ active_resource/railties/log_subscriber.rb:11:in `logger'   /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.0.beta3/lib/action_view/ template.rb:107:in `to_proc'   /usr/lib/ruby/gems/1.8/gems/railties-3.0.0.beta3/lib/rails/ log_subscriber.rb:75:in `map'   /usr/lib/ruby/gems/1.8/gems/railties-3.0.0.beta3/lib/rails/ log_subscriber.rb:75:in `flush_all!'   /usr/lib/ruby/gems/1.8/gems/railties-3.0.0.beta3/lib/rails/rack/ logger.rb:29:in `after_dispatch'   /usr/lib/ruby/gems/1.8/gems/railties-3.0.0.beta3/lib/rails/rack/ logger.rb:15:in `call'   /usr/lib/ruby/gems/1.8/gems/rack-1.1.0/lib/rack/runtime.rb:17:in `call'   /usr/lib/ruby/gems/1.8/gems/rack-1.1.0/lib/rack/lock.rb:11:in `call'   /usr/lib/ruby/gems/1.8/gems/rack-1.1.0/lib/rack/lock.rb:11:in `synchronize'   /usr/lib/ruby/gems/1.8/gems/rack-1.1.0/lib/rack/lock.rb:11:in `call'   /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.0.beta3/lib/ action_dispatch/middleware/static.rb:30:in `call'   /usr/lib/ruby/gems/1.8/gems/railties-3.0.0.beta3/lib/rails/ application.rb:132:in `call'   /usr/lib/ruby/gems/1.8/gems/railties-3.0.0.beta3/lib/rails/ application.rb:81:in `send'   /usr/lib/ruby/gems/1.8/gems/railties-3.0.0.beta3/lib/rails/ application.rb:81:in `method_missing'   /usr/lib/ruby/gems/1.8/gems/railties-3.0.0.beta3/lib/rails/rack/ log_tailer.rb:15:in `call'   /usr/lib/ruby/gems/1.8/gems/rack-1.1.0/lib/rack/content_length.rb: 13:in `call'   /usr/lib/ruby/gems/1.8/gems/rack-1.1.0/lib/rack/handler/webrick.rb: 48:in `service'   /usr/lib/ruby/1.8/webrick/httpserver.rb:104:in `service'   /usr/lib/ruby/1.8/webrick/httpserver.rb:65:in `run'   /usr/lib/ruby/1.8/webrick/server.rb:173:in `start_thread'   /usr/lib/ruby/1.8/webrick/server.rb:162:in `start'   /usr/lib/ruby/1.8/webrick/server.rb:162:in `start_thread'   /usr/lib/ruby/1.8/webrick/server.rb:95:in `start'   /usr/lib/ruby/1.8/webrick/server.rb:92:in `each'   /usr/lib/ruby/1.8/webrick/server.rb:92:in `start'   /usr/lib/ruby/1.8/webrick/server.rb:23:in `start'   /usr/lib/ruby/1.8/webrick/server.rb:82:in `start'   /usr/lib/ruby/gems/1.8/gems/rack-1.1.0/lib/rack/handler/webrick.rb: 14:in `run'   /usr/lib/ruby/gems/1.8/gems/rack-1.1.0/lib/rack/server.rb:155:in `start'   /usr/lib/ruby/gems/1.8/gems/railties-3.0.0.beta3/lib/rails/commands/ server.rb:62:in `start'   /usr/lib/ruby/gems/1.8/gems/railties-3.0.0.beta3/lib/rails/ commands.rb:42   script/rails:9:in `require'   script/rails:9

any help?

I have the same trouble, but using the ruby 1.9.1

it's a kind of bug?

well... finally i installed the ruby head-version, and all the little problems that i had were solved, try that

Thx!