Rails 3 deployment on Passenger

I'm trying to move up to Rails 3 and everything is going fine on my
workstation where I have installed all of the necessary gems. The
problem I'm having is getting it to run on the production server that
I have to use where the app needs to be vendored. It's on a Debian
Squeeze box with ruby l.8.7, rubygems 1.3.6, librack-ruby1.9.1,
passenger - 2.2.11debi and bundler 1.0.0. I have bundled my app via
"bundle install vendor". The passenger error I'm getting is "The
application spawner server exited unexpectedly: Unexpected end-of-file
detected." and in the apache log it says "Could not find rake-0.8.7 in
any of the sources Try running `bundle install`." Updating rack/
passenger/rubygems is not an option. Any thoughts?

try doing gem environment and see where the gem_home is and if is correct

Use Passenger 3. It has better RVM support.

Doh, I pressed 'Send' too quickly. :slight_smile: I meant better Bundler support,
not RVM support. Brightbox has packages for Passenger 3 so upgrading
shouldn't be a problem.