[rails-3.0beta] Problems with routing

Hi,
I'm in the progress of converting an existing Rails 2.3.5 to Rail 3.0-
beta and experiencing some problems.

By now I can start the console through "rails console", database
access etc. works. Alas invoking "rails server" only yields a Routing
Error "no route matches .." for each configured resource.

Funny thing is, that "rake routes" generates a listing of all
configured routes, so this should be some other problem.

The backtrace on the console is:
Started GET "/" for xxx.xxx.xxx.xxx at 2010-02-20 16:52:32
  SQL (0.5ms) SET client_min_messages TO 'panic'
  SQL (0.4ms) SET client_min_messages TO 'notice'
  SQL (0.5ms) SET time zone 'UTC'

ActionController::RoutingError (No route matches "/"):
  /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.0.beta/lib/
action_dispatch/routing/route_set.rb:8
  rack-mount (0.4.0) lib/rack/mount/recognition/route_set.rb:70:in
`call'
  rack-mount (0.4.0) lib/rack/mount/recognition/route_set.rb:70:in
`call'
  rack-mount (0.4.0) lib/rack/mount/recognition/code_generation.rb:
91:in `recognize'
  rack-mount (0.4.0) lib/rack/mount/recognition/code_generation.rb:
73:in `optimized_each'
  rack-mount (0.4.0) lib/rack/mount/recognition/code_generation.rb:
90:in `recognize'
  rack-mount (0.4.0) lib/rack/mount/recognition/route_set.rb:65:in
`call'
  /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.0.beta/lib/
action_dispatch/routing/route_set.rb:419:in `call'
  /usr/lib/ruby/gems/1.8/gems/activerecord-3.0.0.beta/lib/
active_record/query_cache.rb:29:in `call'
  /usr/lib/ruby/gems/1.8/gems/activerecord-3.0.0.beta/lib/
active_record/connection_adapters/abstract/query_cache.rb:34:in
`cache'
  /usr/lib/ruby/gems/1.8/gems/activerecord-3.0.0.beta/lib/
active_record/query_cache.rb:9:in `cache'
  /usr/lib/ruby/gems/1.8/gems/activerecord-3.0.0.beta/lib/
active_record/query_cache.rb:28:in `call'
  /usr/lib/ruby/gems/1.8/gems/activerecord-3.0.0.beta/lib/
active_record/connection_adapters/abstract/connection_pool.rb:365:in
`call'
  /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.0.beta/lib/
action_dispatch/middleware/head.rb:14:in `call'
  rack (1.1.0) lib/rack/methodoverride.rb:24:in `call'
  /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.0.beta/lib/
action_dispatch/middleware/params_parser.rb:20:in `call'
  /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.0.beta/lib/
action_dispatch/middleware/flash.rb:167:in `call'
  /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.0.beta/lib/
action_dispatch/middleware/session/cookie_store.rb:107:in `call'
  /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.0.beta/lib/
action_dispatch/middleware/cookies.rb:205:in `call'
  /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.0.beta/lib/
action_dispatch/middleware/callbacks.rb:46:in `call'
  /usr/lib/ruby/gems/1.8/gems/activesupport-3.0.0.beta/lib/
active_support/callbacks.rb:409:in `_run_call_callbacks'
  /usr/lib/ruby/gems/1.8/gems/activesupport-3.0.0.beta/lib/
active_support/callbacks.rb:88:in `send'
  /usr/lib/ruby/gems/1.8/gems/activesupport-3.0.0.beta/lib/
active_support/callbacks.rb:88:in `run_callbacks'
  /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.0.beta/lib/
action_dispatch/middleware/callbacks.rb:44:in `call'
  /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.0.beta/lib/
action_dispatch/middleware/show_exceptions.rb:62:in `call'
  /usr/lib/ruby/gems/1.8/gems/railties-3.0.0.beta/lib/rails/rack/
logger.rb:13:in `call'
  rack (1.1.0) lib/rack/runtime.rb:17:in `call'
  rack (1.1.0) lib/rack/lock.rb:11:in `call'
  rack (1.1.0) lib/rack/lock.rb:11:in `synchronize'
  rack (1.1.0) lib/rack/lock.rb:11:in `call'
  /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.0.beta/lib/
action_dispatch/middleware/static.rb:30:in `call'
  /usr/lib/ruby/gems/1.8/gems/railties-3.0.0.beta/lib/rails/
application.rb:95:in `call'
  /usr/lib/ruby/gems/1.8/gems/railties-3.0.0.beta/lib/rails/
application.rb:41:in `send'
  /usr/lib/ruby/gems/1.8/gems/railties-3.0.0.beta/lib/rails/
application.rb:41:in `method_missing'
  /usr/lib/ruby/gems/1.8/gems/railties-3.0.0.beta/lib/rails/rack/
log_tailer.rb:15:in `call'
  rack (1.1.0) lib/rack/content_length.rb:13:in `call'
  rack (1.1.0) lib/rack/handler/webrick.rb:48:in `service'
  /usr/lib/ruby/1.8/webrick/httpserver.rb:104:in `service'
  /usr/lib/ruby/1.8/webrick/httpserver.rb:65:in `run'
  /usr/lib/ruby/1.8/webrick/server.rb:173:in `start_thread'
  /usr/lib/ruby/1.8/webrick/server.rb:162:in `start'
  /usr/lib/ruby/1.8/webrick/server.rb:162:in `start_thread'
  /usr/lib/ruby/1.8/webrick/server.rb:95:in `start'
  /usr/lib/ruby/1.8/webrick/server.rb:92:in `each'
  /usr/lib/ruby/1.8/webrick/server.rb:92:in `start'
  /usr/lib/ruby/1.8/webrick/server.rb:23:in `start'
  /usr/lib/ruby/1.8/webrick/server.rb:82:in `start'
  rack (1.1.0) lib/rack/handler/webrick.rb:14:in `run'
  rack (1.1.0) lib/rack/server.rb:155:in `start'
  /usr/lib/ruby/gems/1.8/gems/railties-3.0.0.beta/lib/rails/commands/
server.rb:49:in `start'
  rack (1.1.0) lib/rack/server.rb:83:in `start'
  /usr/lib/ruby/gems/1.8/gems/railties-3.0.0.beta/lib/rails/
commands.rb:39
  script/rails:10:in `require'
  script/rails:10

Rendered /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.0.beta/lib/
action_dispatch/middleware/templates/rescues/routing_error.erb within /
usr/lib/ruby/gems/1.8/gems/actionpack-3.0.0.beta/lib/action_dispatch/
middleware/templates/rescues/layout.erb (0.6ms)

Any ideas what the problem might be?

cheers, Andreas