rails 2.2.2 crash with a kernel protection failure

I am using OS X 10.5.6 gem 1.3.1 and ruby ruby 1.8.7 (2008-08-11 patchlevel 72) [i686-darwin9.6.0] This is the firs time I am trying rails (ever).

At the shell I am trying rails blog and I get

/Library/Ruby/Gems/1.8/gems/hpricot-0.6.164/lib/universal-java1.6/ fast_xs.bundle: [BUG] Bus Error ruby 1.8.7 (2008-08-11 patchlevel 72) [i686-darwin9.6.0]

Abort trap

on a popup I get ruby quit unexpectedly.

EXEC_BAD_ACCESS(SIGABRT) KERN_PROTECTION_FAILURE at 0x00000000

Can someone pleas give me some direction on how to solve this problem.

Thank you all -L

I am using OS X 10.5.6 gem 1.3.1 and ruby ruby 1.8.7 (2008-08-11 patchlevel 72) [i686-darwin9.6.0] This is the firs time I am trying rails (ever).

As a random guess, perhaps the version of fast_xs you have was compiled against a previous version of ruby (eg the 1.8.6 version that comes with OS X). Try removing the hpricot gem and reinstalling it.

Fred

Frederick Cheung wrote: > As a random guess, perhaps the version of fast_xs you have was > compiled against a previous version of ruby (eg the 1.8.6 version that > comes with OS X). Try removing the hpricot gem and reinstalling it.

> Fred

Thanks Fred! That did the trick.

But now Iam getting : script/server /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1. 8/gems/fcgi-0.8.7/lib/fcgi.bundle: [BUG] Bus Error ruby 1.8.7 (2008-08-11 patchlevel 72) [i686-darwin9.6.0]

Abort trap

I did run update_rubygems before this error. Is that means I have to manually remove each gem? That would sound a bit expensive!

only those with a native C component. gem may have a handy shortcut for that, don't know off the top of my head.

Luis,

Did you ever figure this out? I am in the same boat.

Todd

Hi Luis,

I did remove and reinstall each gem. It worked fine and only took a few minutes.

Now I have a new issue I hope someone can help me out with. I am tried to upgrade from source (which I think may have been a mistake, but it's what I'm used to).

I can get the server to start but when I run 'rake' I get the following.

rake aborted! Cipher is not a class /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/ 1.8/openssl/cipher.rb:22 /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `gem_original_require' /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require' *snip*

I am guessing that, like my gems, the openssl lib is not compatible with 1.8.7. Furthermore, Ruby is still looking in /System/Library/ Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8 for libraries.

Is this an issue? Is there an easy way to fix this openssl issue or do more problems await me down the road? More generally, can I do a clean, new install with the libs in, say, /usr/lib/ruby that way I know that everything is up-to-date and compatible?

Thanks, Todd

Well it appears there is one more gem I needed to reinstall: 'rake.' Now it works.

Of course, now I have another issue... Ugh.

Todd Siegel wrote:

Well it appears there is one more gem I needed to reinstall: 'rake.' Now it works.

Of course, now I have another issue... Ugh.

Todd, so far so good. I got all of my gems installed and it is working.

I guess that you like me and others have being updating incrementally. One of my updates got messed up and that started the chain of events. At least that was my case.

-Luis