Rails 1.2.1 console not working

Well, not to state the obvious,but if you look at the gem path above,
you are using rails-1.1.6 , not the 1.2.1 that you think you're using.

Do the Windows and Linux machines both use the same version of rails? I
would check to see what version the Windows machine is using, since it
seems to work on that machine.
matt