rail webrick error

Hi all i am trying to start my app and i got this error how to solve it

=> Booting WEBrick
=> Rails 2.3.8 application starting on http://0.0.0.0:3000
/usr/local/lib/site_ruby/1.8/rubygems.rb:233:in activate': can't activate activesupport (= 2.3.14, runtime) for [], already activated activesupport-2.3.8 for ["rails-2.3.8"] (Gem::LoadError) from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:35:in require’
from /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in require' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:521:in new_constants_in’
from /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in require' from /home/hanish/Honey/PayPal/vendor/plugins/active_merchant/lib/active_merchant.rb:29 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in gem_original_require’
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in require' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in require’
from /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:521:in new_constants_in' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in require’
from /home/khan/Khan/PayPal/vendor/plugins/active_merchant/rails/…/init.rb:1
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in gem_original_require' from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in require’
from /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in require' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:521:in new_constants_in’
from /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in require' from /home/khan/Khan/PayPal/vendor/plugins/active_merchant/rails/init.rb:3:in evaluate_init_rb’
from /usr/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/rails/plugin.rb:158:in evaluate_init_rb' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/core_ext/kernel/reporting.rb:11:in silence_warnings’
from /usr/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/rails/plugin.rb:154:in evaluate_init_rb' from /usr/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/rails/plugin.rb:48:in load’
from /usr/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/rails/plugin/loader.rb:38:in load_plugins' from /usr/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/rails/plugin/loader.rb:37:in each’
from /usr/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/rails/plugin/loader.rb:37:in load_plugins' from /usr/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:369:in load_plugins’
from /usr/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:165:in process' from /usr/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:113:in send’
from /usr/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:113:in run' from /home/khan/Khan/PayPal/config/environment.rb:9 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in gem_original_require’
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in require' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in require’
from /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:521:in new_constants_in' from /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in require’
from /usr/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/commands/server.rb:84
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in gem_original_require' from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in require’
from script/server:3

Cheers

my gem list
actionmailer (2.3.8)
actionpack (2.3.8)
activerecord (2.3.14, 2.3.8)
activeresource (2.3.8)
activesupport (2.3.14, 2.3.8)
declarative_authorization (0.5.5)
mysql (2.8.1)
prawn (0.6.3)
prawn-core (0.6.3)
prawn-format (0.2.3)
prawn-layout (0.3.2)
prawn-security (0.1.1)
rack (1.1.3)
rails (2.3.8)
rake (0.9.2.2)
searchlogic (2.5.8)

Hi ,

Already in your machine 2.3.8 rails version installed,you want to run 2.3.14 rails application.

1.You have to uninstall rails 2.3.8 and install rails 2.3.14 version

gem install rails -v=2.3.14

(Or)

2.Install RVM

https://rvm.io/rvm/install/

Cheers,

Sai

Thanks for your reply ive install rails 2.3.14 also and i get the same error

actionmailer (2.3.14, 2.3.8)

actionpack (2.3.14, 2.3.8)

activerecord (2.3.14, 2.3.8)

activeresource (2.3.14, 2.3.8)

activesupport (2.3.14, 2.3.8)

declarative_authorization (0.5.5)

mysql (2.8.1)

prawn (0.6.3)

prawn-core (0.6.3)

prawn-format (0.2.3)

prawn-layout (0.3.2)

prawn-security (0.1.1)

rack (1.1.3)

rails (2.3.14, 2.3.8)

rake (0.9.2.2)

searchlogic (2.5.8)

ERROR

/usr/local/lib/site_ruby/1.8/rubygems.rb:233:in `activate’: can’t activate activesupport (= 2.3.14, runtime) for [], already activated activesupport-2.3.8 for [“rails-2.3.8”] (Gem::LoadError)

from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:35:in `require'

from /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in `require'

from /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:521:in `new_constants_in'

from /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in `require'

from /home/khan/Khan/PayPal/vendor/plugins/active_merchant/lib/active_merchant.rb:29

from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'

from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'

gem uninstall rails -v=2.3.8

try to run this

I highly advise using rvm, then you can control the different rails
versions more easily.

Colin

But my other apps are running
this is the only line i have in my config/environment.rb file
RAILS_GEM_VERSION = ‘2.3.8’ unless defined? RAILS_GEM_VERSION

my other apps are on 2.3.8 only those are going fine with the same gems