problems with versions of rails

hello everybody.

i have a problem

i beggin in ruby on rails 1 year ago

and i programed an aplication with the next versions..

ruby: 1.8.2

rails 1.1.2

and everithing works very good.

but yesterday i tryed to install ROR in other lap
and the versions are
ruby 1.8.6
rails 2...

the problem that i have is when i run the script "generate scaffol
departamentos"
ror create the files, but when i run the webrick and i went to the
navigator
the page dont work..

i see the extensions files change. i knew .rhtml now are .erb

could you tell me where can i find a new tutorial from the changes
between rails 1.1.2 and rails 2.o

i see the extensions files change. i knew .rhtml now are .erb

could you tell me where can i find a new tutorial from the changes
between rails 1.1.2 and rails 2.o

I doubt you will find that. What you should be able to find is help
going from 1.1.x to 1.2 and then from 1.2 to 2.x (since that's the
path most people will have been down).
When you upgrade to 1.2 you'll probably get a bunch of deprecation
warnings, which are things that change or have been removed in 2.x.
If you get up and running on 1.2 with no warnings 2.x is quite a
smooth upgrade.

Fred