problems with thumbnails, attachment_fu

Hey, I've had this problem for about 2 months and never solved it.

Image model:   has_attachment :content_type => :image,                   :max_size => 7.megabytes,                   :resize_to => '1000x100>',                   :storage => :file_system,                   :thumbnails => {                                     :tinyThumb => '144x108',                                     :mediumThumb => '200x150'                   }

This leaves me with 3 files in upload folder 1- 144x108 - correct 2 - 200x150 - incorrect It seems to completely ignore the fact i want a 1000x1000 resized copy. And for some reason gives me two mediumThumbs.

If i remove the resize_to alltogether I get the same results.

I tried adding: :thumbnails => {                                     :tinyThumb => '144x108',                                     :mediumThumb => '200x150',                                     :large => '1000x1000>'                   }

This leaves me 4 files. For what reason i have no idea. 2xtinyThumb- 144x108 - incorrect 2xmediumThumb- 200x150 - incorrect

My experience with attachment_fu so far has been inconsistant at best. I cant find any solutions for the problem anywhere.

Also I do not recall which image processor i installed 2months ago. I was going to start toying with attachment_fu's processor specific functions for better thumbnail quality. They look like garbage as is. So if anyone knows a way I can find that out that would be nice.