Problem installing Rails 2.1.1 under Suse LINUX - Help needed!

Team,

While installing Rails 2.1.1 unde Suse Linux, I came across an error
msg telling me that I need this library, libopenssl-ruby.

I am running LINUX Suse: 2.6.16.21-0.8-smp.

ruby -v
ruby 1.8.6 (2008-08-08 patchlevel 286) [i686-linux]

I performed a google search and the results was to get the libopenssl-
ruby library.
I don't know where this library is and how to install it.
This is my first experience with Rails and I've been trying to fix
this problem for a few days now. I posted questions on the Ruby forum
unsuccessfully.

Any help is greatly appreciated!

Thank you

nyc-linux-suse170:/local/demo # ruby script/server
=> Booting WEBrick...
/usr/local/lib/ruby/gems/1.8/gems/rails-2.1.1/lib/initializer.rb:
229:in `require_frameworks': no such file to load -- openssl
(RuntimeError) from
/usr/local/lib/ruby/gems/1.8/gems/rails-2.1.1/lib/initializer.rb:
118:in `process' from
/usr/local/lib/ruby/gems/1.8/gems/rails-2.1.1/lib/initializer.rb:97:in
`send' from
/usr/local/lib/ruby/gems/1.8/gems/rails-2.1.1/lib/initializer.rb:97:in
`run' from
/local/demo/config/environment.rb:13 from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require'
       from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
       from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.1.1/lib/
active_support/dependencies.rb:510:in
`require'
       from
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.1.1/lib/
active_support/dependencies.rb:355:in
`new_constants_in'
        ... 7 levels...
       from
/usr/local/lib/ruby/gems/1.8/gems/rails-2.1.1/lib/commands/server.rb:
39
       from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require'
       from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
       from script/server:3

I know very little about SUSE, but could this thread be helpful?

http://www.mail-archive.com/capistrano@googlegroups.com/msg01833.html

Yes, it’s about capistrano, but it involves making SSL work w/ Ruby on SUSE.

Regards,
Craig

Hi, I know little about suse as well. I think the package manager is
yast - isn't it? Did you install ruby through suse or from source?

What do you get when you try to require 'openssl' - here's my session
using irb:
danb@lin4:~$ irb
irb(main):001:0> require 'openssl'
=> true
irb(main):002:0>

If you're getting a load file error here then:

If you installed ruby through suse packages load up yast (or whatever
it is) and browse through the ruby stuff and look for ruby add-on
packages. For instance, in debian there's a libopenssl-ruby package
which I can load with aptitude/apt-get (debian's equivalent of yast).

[Someone who knows suse could step in here.]

If you compiled and installed from source (your ruby is probably in /
usr/local/bin or /opt ), then I would install the header files for
openssl using suse's package manager (as well as openssl itself) and
then recompile ruby. I think openssl-devel might be the package to
look for in yast (or whatever it is).