"Plugin not found"

I'm using Ruby 1.8.7 and Rails 2.3.5. I'm in a Windows XP environment.

Whenever I run ruby script/plugin install yada/yada/yada I get:

Plugin not found ["yada yada yada]"

It doesn't matter if I use git://, http://git., http://svn, with or
without a trailing slash, or even if I download the source code
directly to vendor/plugins and give the path. It always fails.

I've had this problem today with both attachment_fu and will_paginate.

Marc Luzietti

Hi Marc,

I'm having the same problem where you able to find a solution ?

I had the same problem with acts_as_list and acts_as_tree plugins.
i actually broke my head on it!!!!!

finally i solved it by manually installing plugins in /"my project's

just download your plugin from github (i did it from here) as a source
code archive and unzip it where i told you :slight_smile: so you'll ges smth like:
rails will automatically load it when runs! :slight_smile:

The solution for me was to download Bitnami's Rubystack, and do my
development through it. After that, the known work around, using
http://svn…git/ with the trailing slash after .git works for me.

I had same problem two days ago, and finally I figured it out my
problem. I have window xp too.

step 1) download and install git.
step 2) use gitbash to setup SSH, it will generate a publich key and
you have to register this publish key in github.com with your email
account. then you will have secured connection when you install those
step 3) in gitblash, script/install plugin git://github.com/bla/bla/bla.git.


just change
stream.reopen(RUBY_PLATFORM =~ /mswin/ ? 'NUL:' : '/dev/null')

this because when you type in the console

ruby --version
ruby 1.8.7 (2010-01-10 patchlevel 249) [i386-mingw32]

in the

it checks
stream.reopen(RUBY_PLATFORM =~ /mswin/ ? 'NUL:' : '/dev/null')

so the i386-mingw32 does contains mswin so it always use '/dev/null' but
it should use 'NUL:' in windows to just change
stream.reopen(RUBY_PLATFORM =~ /mswin/ ? 'NUL:' : '/dev/null')

and it will works

Thank you Ahmed Mohamed.

I really wish there was more collection of such solution for Windows
platform on the Web.
Good job.