Perhaps not the correct group...

But I was not sure where to go with this. I am trying to add rspec
testing to a "working" application and get the following error.

/Library/Ruby/Gems/1.8/gems/color-1.4.0/lib/color.rb:19: Color is not
a module (TypeError)
  from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
  from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
`polyglot_original_require'
  from /Library/Ruby/Gems/1.8/gems/polyglot-0.2.8/lib/polyglot.rb:68:in
`require'
  from /Library/Ruby/Gems/1.8/gems/activesupport-2.3.2/lib/
active_support/dependencies.rb:158:in `require'
  from /Library/Ruby/Gems/1.8/gems/pdf-writer-1.1.8/lib/pdf/writer.rb:
15
  from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:36:in
`gem_original_require'
  from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:36:in
`polyglot_original_require'
  from /Library/Ruby/Gems/1.8/gems/polyglot-0.2.8/lib/polyglot.rb:68:in
`require'
   ... 13 levels...
  from /Library/Ruby/Gems/1.8/gems/rspec-1.2.8/lib/spec/runner/
command_line.rb:9:in `run'
  from /Library/Ruby/Gems/1.8/gems/rspec-1.2.8/bin/spec:4
  from /usr/bin/spec:19:in `load'
  from /usr/bin/spec:19

I don't really understand; I have not changed my environment except
for recently updating all of my gems.

I apologize if this is the wrong group but any pointers would be
appreciated.

rick

I think you almost answered your own question... Looks like you
updated the color gem and now it is conflicting with something else in
your application that has Color defined.

I would start with a project wide search to find Color to see if there
is something else that defines Color.