I believe there is a naming convention to follow if you're using
the :collection option. if your collection is called @posts your
partial should be called the singular (_post.html.erb).
<%= render :partial => :post, :collection => @posts %>
I'm sure there are other (better) ways to do this... I've had success
following this convention tho.