Paperclip - 'identify' command.

I'm following this tutorial:
http://jimneath.org/2008/04/17/paperclip-attaching-files-in-rails/

When it comes to running the application, I get the following errors:

-Photo C:/Users/ABDER-~1/AppData/Local/Temp/stream,2396,0.jpg is not
recognized by the 'identify' command.
-Photo C:/Users/ABDER-~1/AppData/Local/Temp/stream,2396,0.jpg is not
recognized by the 'identify' command.

Why is that?

Thanks.

I followed the issue following this:

I just needed to replace the "'#{m}'" with "\"#{m}
\"" in the quote_command_options method.

def quote_command_options(*options)
      options.map do |option|
        option.split("'").map{|m| "\"#{m}\"" }.join("\\'")
      end
    end

From:
http://groups.google.com/group/paperclip-plugin/browse_thread/thread/c69df6fbeb0ba30d

Abder-Rahman Ali wrote:

I followed the issue following this:

I just needed to replace the "'#{m}'" with "\"#{m}
\"" in the quote_command_options method.

def quote_command_options(*options)
      options.map do |option|
        option.split("'").map{|m| "\"#{m}\"" }.join("\\'")
      end
    end

From:
http://groups.google.com/group/paperclip-plugin/browse_thread/thread/c69df6fbeb0ba30d

I 'followed' the issue ---> I solved the issue :wink:

install imagemagick if you are in windows there is a problem with the command paperclip user since it call the shell as if is a linux shell and you get that errot try upgrading paperclip if it still not working , reply with a bit more info.

but is mainly a problem with imagemagick

Thanks @radhames. As yo cn see I have included a workaround to be
working for the mean while.