paperclip gem install failed

when i'm installing paperclip gem its return err (i18n requires
RubyGems version >= 1.3.6)
the os is ubuntu 10.04 64bit
-nirosh-

nirosh wrote:

when i'm installing paperclip gem its return err (i18n requires
RubyGems version >= 1.3.6)
the os is ubuntu 10.04 64bit
-nirosh-

sudo gem update --system

should get you to rubygems 1.3.7 on 10.04 64-bit (just did for me - now
to see what I just broke!!! lol. I followed with a 'sudo gem update'
just for fun - no this isn't my main dev machine)

can't run gem --update on Debian based Systems.
anyway when i'm try to generate paperclip model (script/generate
paperclip album_set photo) the error was

/var/lib/gems/1.8/gems/activesupport-2.3.5/lib/active_support/
dependencies.rb:440:in `load_missing_constant': uninitialized constant
Paperclip::Glue (NameError)
  from /var/lib/gems/1.8/gems/activesupport-2.3.5/lib/active_support/
dependencies.rb:80:in `const_missing'
  from /home/ozoner/Desktop/PhotoAlbum/vendor/plugins/paperclip/lib/
paperclip/railtie.rb:20:in `insert'
  from /home/ozoner/Desktop/PhotoAlbum/vendor/plugins/paperclip/rails/
init.rb:2:in `evaluate_init_rb'
  from /var/lib/gems/1.8/gems/rails-2.3.5/lib/rails/plugin.rb:158:in
`evaluate_init_rb'
  from /var/lib/gems/1.8/gems/activesupport-2.3.5/lib/active_support/
core_ext/kernel/reporting.rb:11:in `silence_warnings'
  from /var/lib/gems/1.8/gems/rails-2.3.5/lib/rails/plugin.rb:154:in
`evaluate_init_rb'
  from /var/lib/gems/1.8/gems/rails-2.3.5/lib/rails/plugin.rb:48:in
`load'
  from /var/lib/gems/1.8/gems/rails-2.3.5/lib/rails/plugin/loader.rb:
38:in `load_plugins'
  from /var/lib/gems/1.8/gems/rails-2.3.5/lib/rails/plugin/loader.rb:
37:in `each'
  from /var/lib/gems/1.8/gems/rails-2.3.5/lib/rails/plugin/loader.rb:
37:in `load_plugins'
  from /var/lib/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:369:in
`load_plugins'
  from /var/lib/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:165:in
`process'
  from /var/lib/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:113:in
`send'
  from /var/lib/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:113:in
`run'
  from /home/ozoner/Desktop/PhotoAlbum/config/environment.rb:9
  from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
  from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `require'
  from /var/lib/gems/1.8/gems/rails-2.3.5/lib/commands/generate.rb:1
  from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
  from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `require'
  from script/generate:3

problem fixed with sudo gem install paperclip -v 2.3.1.1 command